Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1363828 - iSCSI sessions are disconnected early when deleting all volume backed instances from a host
Summary: iSCSI sessions are disconnected early when deleting all volume backed instanc...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova
Version: 7.0 (Kilo)
Hardware: x86_64
OS: Linux
high
high
Target Milestone: async
: 7.0 (Kilo)
Assignee: Lee Yarwood
QA Contact: Prasanth Anbalagan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-03 16:34 UTC by Lee Yarwood
Modified: 2017-09-26 19:33 UTC (History)
12 users (show)

Fixed In Version: openstack-nova-2015.1.4-15.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-05 19:16:03 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2025 normal SHIPPED_LIVE openstack-nova bug fix advisory 2016-10-05 23:12:09 UTC

Description Lee Yarwood 2016-08-03 16:34:30 UTC
Description of problem:
iSCSI sessions are disconnected early when deleting all volume backed instances from a host. 

This is due to the instances being shutdown prior to a lookup being preformed of block devices being used by running instances during each disconnect_volume call. This becomes an issue if dm-multipath is used on the host and is configured with queue_if_no_path as systemd-udev etc may hang forever waiting for the iSCSI sessions to reappear.

Version-Release number of selected component (if applicable):
OSP 7

How reproducible:
Always

Steps to Reproduce:
1. Run multiple volume backed instances on a single compute node.
2. Remove all of these instances from the host at the same time.

Actual results:
iSCSI sessions are disconnected early prior to all volumes being disconnected.

Expected results:
iSCSI sessions are only disconnected during the final disconnect_volume call.

Additional info:
More details in the following comments where this was initially discovered.
https://bugzilla.redhat.com/show_bug.cgi?id=1351169#c55
https://bugzilla.redhat.com/show_bug.cgi?id=1351169#c57

Comment 4 errata-xmlrpc 2016-10-05 19:16:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2025.html


Note You need to log in before you can comment on or make changes to this bug.