Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1363824 - context variables for DWH are not the same type as in engine
Summary: context variables for DWH are not the same type as in engine
Keywords:
Status: CLOSED DUPLICATE of bug 1263785
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: General
Version: 4.0.1.1
Hardware: Unspecified
OS: Unspecified
low
low vote
Target Milestone: ovirt-4.1.0-beta
: ---
Assignee: Ido Rosenzwig
QA Contact: Lukas Svaty
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-03 16:23 UTC by Fabrice Bacchella
Modified: 2016-12-29 10:08 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-29 10:08:13 UTC
oVirt Team: Integration
ylavi: ovirt-4.1?
rule-engine: planning_ack?
sbonazzo: devel_ack+
lsvaty: testing_ack+


Attachments (Terms of Use)

Description Fabrice Bacchella 2016-08-03 16:23:55 UTC
If I look it /var/log/ovirt-engine/setup/ovirt-engine-setup-....log after upgrading from 3.6 to 4.0, I see a funny result:

2016-08-03 11:23:11 DEBUG otopi.context context.dumpEnvironment:770 ENV OVESETUP_DB/port=int:'5432'
2016-08-03 11:38:27 DEBUG otopi.context context.dumpEnvironment:770 ENV OVESETUP_DWH_DB/port=str:'5432'


The DWH DB configuration code seems to be very different from the DB configuration, so there is duplicated code and source of bug like #1363816

Comment 1 Yaniv Lavi 2016-08-11 08:23:14 UTC
This is by design, since the engine DB and the DWH DB don't have to be in the same location.

Comment 2 Ido Rosenzwig 2016-12-29 10:08:13 UTC
Fixed on https://bugzilla.redhat.com/1263785

*** This bug has been marked as a duplicate of bug 1263785 ***


Note You need to log in before you can comment on or make changes to this bug.