Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1363812 - qemu-kvm-rhev: -cpu POWER8 no longer works
Summary: qemu-kvm-rhev: -cpu POWER8 no longer works
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.3
Hardware: ppc64le
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Thomas Huth
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-03 15:56 UTC by Andrea Bolognani
Modified: 2016-11-07 21:28 UTC (History)
6 users (show)

Fixed In Version: qemu-kvm-rhev-2.6.0-21.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-07 21:28:25 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2673 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2016-11-08 01:06:13 UTC

Description Andrea Bolognani 2016-08-03 15:56:48 UTC
Running

  qemu-kvm -M pseries,accel=kvm -cpu POWER8

used to work, but now fails with

  qemu-kvm: Register sync failed... If you're using kvm-hv.ko,
  only "-cpu host" is possible
  kvm_init_vcpu failed: Invalid argument

This is very problematic, as libvirt guests that follow the
recommended configuration, eg.

  <cpu mode='custom' match='exact'>
    <model fallback='allow'>POWER8</model>
  </cpu>

will no longer boot.

git bisect narrowed this down to upstream commit

  commit 3b542549661eb216580e8b7683e13caa3950da45
  Author: Bharata B Rao <bharata@linux.vnet.ibm.com>
  Date:   Fri Jun 10 06:29:01 2016 +0530

      spapr: Abstract CPU core device and type specific core devices

      Add sPAPR specific abastract CPU core device that is based on generic
      CPU core device. Use this as base type to create sPAPR CPU specific core
      devices.

      TODO:
      - Add core types for other remaining CPU types
      - Handle CPU model alias correctly

      Signed-off-by: Bharata B Rao <bharata@linux.vnet.ibm.com>
      Signed-off-by: David Gibson <david@gibson.dropbear.id.au>

which was recently backported as part of the CPU hotplug
support.


kernel-3.10.0-482.el7.ppc64le
qemu-kvm-rhev-2.6.0-17.el7.ppc64le

Comment 1 Qunfang Zhang 2016-08-04 03:29:09 UTC
Reproduced on qemu-kvm-rhev-2.6.0-17.el7.ppc64le.

# /usr/libexec/qemu-kvm -cpu POWER8
qemu-kvm: Register sync failed... If you're using kvm-hv.ko, only "-cpu host" is possible
kvm_init_vcpu failed: Invalid argument

It used to work according to bug 1291209 comment 9. Setting Regression keywords.

Comment 3 Thomas Huth 2016-08-09 09:00:15 UTC
Just a comment to state again that this is not just a cosmetic issue: libvirt depends on the behavior that it is possible to use "-cpu POWER8" on a POWER8E host, too. This behavior has been discussed between libvirt and QEMU folks in the past and it's been decided that it's up to QEMU to take care of the POWER8 version handling here (see the mail thread at https://lists.gnu.org/archive/html/qemu-devel/2015-07/msg02257.html for example). So we need to fix this regression in QEMU.

Comment 4 Miroslav Rezanina 2016-08-16 11:23:50 UTC
Fix included in qemu-kvm-rhev-2.6.0-21.el7

Comment 6 Min Deng 2016-08-23 07:46:39 UTC
Reproduce the issue on build qemu-kvm-rhev-2.6.0-17.el7.ppc64le
steps please refer to comments 1
Verified the build on build qemu-kvm-rhev-2.6.0-22.el7.ppc64le
So the bug should be fixed,thanks a lot.

Comment 8 errata-xmlrpc 2016-11-07 21:28:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2673.html


Note You need to log in before you can comment on or make changes to this bug.