Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1363805 - [FC24] otopi minidnf fails on fedora 24
Summary: [FC24] otopi minidnf fails on fedora 24
Keywords:
Status: CLOSED DUPLICATE of bug 1361888
Alias: None
Product: otopi
Classification: oVirt
Component: Plugins.packagers
Version: master
Hardware: x86_64
OS: Linux
unspecified
high vote
Target Milestone: ovirt-4.1.0-alpha
: ---
Assignee: Yedidyah Bar David
QA Contact: Petr Kubica
URL:
Whiteboard:
: 1363785 (view as bug list)
Depends On:
Blocks: oVirt_Fedora24_Support
TreeView+ depends on / blocked
 
Reported: 2016-08-03 15:34 UTC by Yedidyah Bar David
Modified: 2017-05-11 09:27 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1363785
Environment:
Last Closed: 2016-09-05 14:15:17 UTC
oVirt Team: Integration
rule-engine: ovirt-4.1+
rule-engine: blocker+
ylavi: Triaged+
ylavi: planning_ack+
sbonazzo: devel_ack+
lsvaty: testing_ack+


Attachments (Terms of Use)

Description Yedidyah Bar David 2016-08-03 15:34:50 UTC
+++ This bug was initially created as a clone of Bug #1363785 +++

Description of problem:
running a python application called engine-setup from oVirt project which relies on python bindings for dnf.

The python interpreter crashes and generates a coredump, see abrt report attached (didn't work automatically since the otopi package is not part of Fedora)

It's not caused by selinux denials:
# ausearch -m avc
<no matches>

It's 100% reproducible:
 # dnf install python2-dnf.noarch
 # dnf install http://resources.ovirt.org/pub/yum-repo/ovirt-release-master.rpm
 # dnf install ovirt-engine
 # engine-setup

On fedora 23 worked fine.

--- Additional comment from Sandro Bonazzola on 2016-08-03 17:41 IDT ---



--- Additional comment from Yedidyah Bar David on 2016-08-03 18:32:07 IDT ---

The attached stack trace has:

\#3  0x00007f69f50c9042 in __GI___assert_fail (assertion=0x7f69e2796727 "hrepo->state_main == _HY_NEW", file=0x7f69e2796538 "/builddir/build/BUILD/hawkey-0.6.3/src/sack.c"

\#9  PyEval_EvalFrameEx (f=f@entry=Frame 0x555c708d9670, for file /usr/lib/python2.7/site-packages/dnf/base.py, line 127, in _add_repo_to_sack

\#13 PyEval_EvalFrameEx (f=f@entry=Frame 0x555c70862720, for file /usr/lib/python2.7/site-packages/dnf/base.py, line 239, in fill_sack

\#17 PyEval_EvalFrameEx (f=f@entry=Frame 0x7f69deb31420, for file /usr/lib/python2.7/site-packages/otopi/minidnf.py, line 530, in clean 

Still not sure about the root cause, taking to otopi for now. Will move back to python/dnf/hawkey if relevant.

--- Additional comment from Yedidyah Bar David on 2016-08-03 18:33:58 IDT ---

Can't take to otopi because bugzilla requires oVirt Team but does not allow setting one... Cloning.

Comment 1 Yedidyah Bar David 2016-08-03 15:36:35 UTC
*** Bug 1363785 has been marked as a duplicate of this bug. ***

Comment 2 Red Hat Bugzilla Rules Engine 2016-08-11 08:20:25 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 3 Yedidyah Bar David 2016-09-05 14:15:17 UTC

*** This bug has been marked as a duplicate of bug 1361888 ***


Note You need to log in before you can comment on or make changes to this bug.