Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1363792 - ncurses: 'tput reset' outputs ' ^[]104' after terminal is cleared
Summary: ncurses: 'tput reset' outputs ' ^[]104' after terminal is cleared
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: terminator
Version: 24
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Dominic Hopf
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-03 14:56 UTC by David Kaspar [Dee'Kej]
Modified: 2017-03-09 12:49 UTC (History)
4 users (show)

Fixed In Version: terminator-1.90-1.fc25 terminator-1.91-1.fc24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-09 12:49:04 UTC


Attachments (Terms of Use)

Description David Kaspar [Dee'Kej] 2016-08-03 14:56:01 UTC
Description of problem:
I have 'tput reset' command in my /etc/bashrc file, to clean my terminal when I switch from user to root, or vice versa. Now, after today's update I see 5 strange characters displayed after the command 'tput reset' is finished:

]104


Version-Release number of selected component (if applicable):
ncurses-6.0-5.20160116.fc24.x86_64
terminator-0.98-3.fc24.noarch

How reproducible:
Always.


Steps to Reproduce:
1. Install packages above (terminator, ncurses).
2. Run 'terminator'.
3. Run 'tput reset' command.


Actual results:
]104dkaspar@Normandy-SR4 ~ $ 


Expected results:
dkaspar@Normandy-SR4 ~ $ 


Additional info:
This problem does not occur with 'gnome-terminal'. I started to see these symbols after today's update, I haven't had this problem with previous versions.

Comment 1 David Kaspar [Dee'Kej] 2016-08-03 14:59:58 UTC
Bugzilla is not able to display the first character I see. When I copy those characters to vim, I see this sequence:

^[]104

where ^[ is highlighted as an (terminal?) escape sequence. I hope this helps.

Comment 2 Miroslav Lichvar 2016-08-04 06:43:27 UTC
terminator seems to be setting TERM to xterm-256color, so this is probably due to the recent ncurses update, which updated the reset string for xterm in order to reset palette. That sequence is apparently not supported by the old vte used by terminator.

If vte used its own terminfo entry, it wouldn't have to be catching up with changes in xterm and this wouldn't be a problem.

Comment 3 Egmont Koblinger 2016-08-04 07:51:19 UTC
(In reply to Miroslav Lichvar from comment #2)

> If vte used its own terminfo entry, it wouldn't have to be catching up with
> changes in xterm and this wouldn't be a problem.

If termniator finally released a gtk3 tarball (https://bugs.launchpad.net/terminator/+bug/1030562) or Red Hat switched to that bzr branch, in order to use a recent and maintained vte rather than a 5 year old unmaintained and heavily buggy one, this wouldn't be a problem either.

Comment 4 David Kaspar [Dee'Kej] 2016-08-08 12:46:52 UTC
(In reply to Egmont Koblinger from comment #3)
> (In reply to Miroslav Lichvar from comment #2)
> 
> > If vte used its own terminfo entry, it wouldn't have to be catching up with
> > changes in xterm and this wouldn't be a problem.
> 
> If termniator finally released a gtk3 tarball
> (https://bugs.launchpad.net/terminator/+bug/1030562) or Red Hat switched to
> that bzr branch, in order to use a recent and maintained vte rather than a 5
> year old unmaintained and heavily buggy one, this wouldn't be a problem
> either.

Can we actually get bazaar stuff into Fedora? Aren't there some licensing issues?

Also, I would like to point out that Red Hat is not single-handedly responsible for Fedora... The Terminator package is being maintained by someone outside Red Hat. This is a community project, which Red Hat sponsors. Not the other way... :)

Comment 5 Egmont Koblinger 2016-08-08 12:55:35 UTC
(In reply to David Kaspar [Dee'Kej] from comment #4)

> Can we actually get bazaar stuff into Fedora? Aren't there some licensing
> issues?

I really doubt it. It's the source code that has a certain license, and it should not vary based on whether you take a tarball or check out from vcs. I am not a lawyer though.

> Also, I would like to point out that Red Hat is not single-handedly
> responsible for Fedora... The Terminator package is being maintained by
> someone outside Red Hat. This is a community project, which Red Hat
> sponsors. Not the other way... :)

Thanks for the clarification, apparenty I meant Fedora instead.

Seriously: I believe the correct way to resolve this bug would be for Fedora to switch to the latest bzr version, plus perhaps 3 more patches applied accordingly to the aforementioned upstream bug. This approach would fix hundreds of other bugs at the same time in vte (the actual terminal emulation) and Terminator itself would also be at least as good as previously. (Apparently upstream maintainer is not responsive and does not intend to release a gtk3 tarball, I do not understand why.)

Comment 6 Kevin Fenzi 2016-08-08 15:17:05 UTC
So, I am unsure how to fix this in vte or if it should be even. 

Perhaps we should move this bug to terminator and ask the maintainer if they can move to the gtk3 version?

I'd really like to move all the old terminals that are still gtk2 to gtk3 and retire this old unsupported vte.

Comment 7 David Kaspar [Dee'Kej] 2016-08-08 15:34:01 UTC
2 All: I think both of the issues should be solved, but probably separately.

For this BZ, I think the most sense makes to switch it to Terminator and ask the maintainer if he could upgrade it to GTK3.

As for the vte, I think if there are any problems with maintainership and the package is getting outdated, we should write to fedora-devel mailing list and discuss further development with community. They might have some crucial context that we might be missing here...

Could anyone start the conversation on the mailing list? I'm currently engaged in other matters... :-/

Comment 8 Egmont Koblinger 2016-08-08 15:41:52 UTC
(In reply to Kevin Fenzi from comment #6)

> Perhaps we should move this bug to terminator and ask the maintainer if they
> can move to the gtk3 version?

That's what I think the proper solution would be. (Well, the really proper one would be if the developer released a tarball, but that's out of your control.)

Based on the changelog of vte for the last ~5 years, one could file perhaps another 100 bugs assigned to terminator or old vte, the majority of them probably more serious than the current one. So I see absolutely no point in trying to fix/upgrade/patch/maintain an ancient unmaintained vte.

(In reply to David Kaspar [Dee'Kej] from comment #7)

> As for the vte, [...]

Just for the record, I've been an active contributor/developer of vte in the last almost 3 years. According to my best knowledge, neither myself, nor the main developer has any interest in working on the old gtk2 version. If anyone volunteered in maintaining that, I would personally find that a total waste of resources that should instead be spent on porting these apps to gtk3 and fixing the remaining issues there.

Comment 9 Kevin Fenzi 2016-08-08 15:43:33 UTC
(In reply to David Kaspar [Dee'Kej] from comment #7)
> 2 All: I think both of the issues should be solved, but probably separately.
> 
> For this BZ, I think the most sense makes to switch it to Terminator and ask
> the maintainer if he could upgrade it to GTK3.

Sure. 
 
> As for the vte, I think if there are any problems with maintainership and
> the package is getting outdated, we should write to fedora-devel mailing
> list and discuss further development with community. They might have some
> crucial context that we might be missing here...

Unlikely. This vte is the last shipped version that supported gtk2. 
There is no upstream development on it. It gets no bugfixes or updates. 

I've only kept it around since I need it for xfce4-terminal, which has since moved to gtk3. So, I'd like to look at urging the last stragglers here to move to gtk3 so we can retire it. 

> 
> Could anyone start the conversation on the mailing list? I'm currently
> engaged in other matters... :-/

I don't see a need...

Comment 10 Kevin Fenzi 2016-08-08 15:44:52 UTC
Moving to terminator maintainer(s) for comment on upgrading terminator to gtk3...

Comment 11 David Kaspar [Dee'Kej] 2016-08-09 08:52:38 UTC
Thank you guys for the clarification. I didn't understand the situation completely before. What you've written make sense. :)

Comment 12 Dominic Hopf 2016-08-09 20:21:53 UTC
Ok guys, so here is a first try of a GTK3 package of Terminator:

https://dmaphy.fedorapeople.org/terminator/terminator-0.99-0.3.1753bzr.fc24.noarch.rpm

The source package is here:

https://dmaphy.fedorapeople.org/terminator/terminator-0.99-0.3.1753bzr.fc24.src.rpm


Apparently I've built it from the bazaar branch, but without applying any additional patches to it (just one small fix for the .desktop-file).

Please keep in mind that this is no official Fedora Package yet, since the GTK3 version even isn't released upstream.

I'm not sure how to proceed properly to get this into Fedora without an official upstream release tarball, my approach would be to make this available for Rawhide in a first step.

Feel free to check it out and let me know of any issues you have with this package.

Comment 13 Dominic Hopf 2016-08-09 20:31:35 UTC
Oh, and if you prefer Copr this would be the way to go for now: https://copr.fedorainfracloud.org/coprs/dmaphy/Terminator/.

Comment 14 Egmont Koblinger 2016-08-09 20:39:47 UTC
Thanks!

I've no clue what's Fedora's policy wrt. unreleased versions, so I cannot help you there.

My installation of terminator from bzr reports version number 0.97 if I invoke "terminator --version". Not sure about your package. If that one too, probably it should be patched.

According to the discussion in that bug, gtk3 tarballs are expected to be numbered 1.97-1.98-1.99-ish and then hit 2.0 at some point. Version numbers 0.99 and 1.0 are to be used for future gtk2 releases (if any).

I don't know if you, on behalf of Fedora or Red Hat, pinging the maintainer would have any effect. He hasn't done any noticeable work in like 8 months now, doesn't respond to questions about gtk3 tarballs, yet every once in a while he comments on other bugs. Maybe if he sees some pressure from others, not just me, that could make a difference.

On a side note: Given the terribly poor maintenance and lack of communication by the author, and getting stuck at an ancient vte version, maybe this package could be obsoleted/removed. Terminix [https://github.com/gnunn1/terminix] is a great replacement with similar paned layout, being actively developed, and is based on newest vte. At the very least it would be nice if Fedora / Red Hat also shipped Terminix.

Comment 15 David Kaspar [Dee'Kej] 2016-08-10 11:00:32 UTC
Hello!

(In reply to Dominic Hopf from comment #12)
> Ok guys, so here is a first try of a GTK3 package of Terminator:
> 
> https://dmaphy.fedorapeople.org/terminator/terminator-0.99-0.3.1753bzr.fc24.
> noarch.rpm

I'm testing it right now. This version solves the problem reported in this BZ. I will keep testing it and let you know if I find any other issues.

By the way, I think it should be possible to make packages from something other than source tarball. The package has to be changed a little, if I'm not mistaken. I will ask my peer once he gets back from his PTO. :)


(In reply to Egmont Koblinger from comment #14)
> I don't know if you, on behalf of Fedora or Red Hat, pinging the maintainer
> would have any effect. He hasn't done any noticeable work in like 8 months
> now, doesn't respond to questions about gtk3 tarballs, yet every once in a
> while he comments on other bugs. Maybe if he sees some pressure from others,
> not just me, that could make a difference.
I guees giving it a shot will not hurt anything. Do you have a link to contact upstream? Googling brought a bunch of different results for me, and I'm not sure if Launchpad guys are considered upstream right now.

> On a side note: Given the terribly poor maintenance and lack of
> communication by the author, and getting stuck at an ancient vte version,
> maybe this package could be obsoleted/removed. Terminix
> [https://github.com/gnunn1/terminix] is a great replacement with similar
> paned layout, being actively developed, and is based on newest vte. At the
> very least it would be nice if Fedora / Red Hat also shipped Terminix.
Getting Terminix inside Fedora is a good idea. However, I would be careful about removing/replacing Terminator. Many peopla that I know rely on it heavily, so that would make a lot of people angry... Just saying. :)

Comment 16 Egmont Koblinger 2016-08-10 11:18:05 UTC
It's officially hosted on Launchpad, and there's a blog at http://gnometerminator.blogspot.hu/. The maintainer is Stephen Boddy.

Comment 17 David Kaspar [Dee'Kej] 2016-08-10 13:48:04 UTC
(In reply to Dominic Hopf from comment #12)
> I'm not sure how to proceed properly to get this into Fedora without an
> official upstream release tarball, my approach would be to make this
> available for Rawhide in a first step.

https://fedoraproject.org/wiki/Packaging:SourceURL

From the page above:
"""
There are several cases where upstream is not providing the source to you in an upstream tarball. In these cases you must document how to generate the tarball used in the rpm either through a spec file comment or a script included as a separate SourceX:.
"""

Comment 18 Fedora Update System 2016-11-24 10:41:41 UTC
terminator-1.90-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ec937ddb3c

Comment 19 Fedora Update System 2016-11-24 10:42:22 UTC
terminator-1.90-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-082f9377fd

Comment 20 Fedora Update System 2016-11-25 09:39:56 UTC
terminator-1.90-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-ec937ddb3c

Comment 21 Fedora Update System 2016-11-25 09:43:05 UTC
terminator-1.90-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-082f9377fd

Comment 22 Fedora Update System 2016-11-30 05:29:01 UTC
terminator-1.90-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 23 Fedora Update System 2016-12-04 15:57:37 UTC
terminator-1.90-5.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-77620715b6

Comment 24 Fedora Update System 2016-12-06 03:59:39 UTC
terminator-1.90-5.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-77620715b6

Comment 25 Fedora Update System 2017-02-27 10:51:18 UTC
terminator-1.91-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-e906b78dcf

Comment 26 Fedora Update System 2017-02-27 23:51:51 UTC
terminator-1.91-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-e906b78dcf

Comment 27 Fedora Update System 2017-03-09 12:49:04 UTC
terminator-1.91-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.