Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1363786 - [RFE] thin logical volumes not found by libvirt
Summary: [RFE] thin logical volumes not found by libvirt
Keywords:
Status: CLOSED DUPLICATE of bug 1060287
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Libvirt Maintainers
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-03 14:40 UTC by Marian Csontos
Modified: 2016-08-03 14:52 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-03 14:52:17 UTC


Attachments (Terms of Use)

Description Marian Csontos 2016-08-03 14:40:54 UTC
Description of problem:
`virsh vol-list --pool VG` does not list existing thin volumes.

Basically, anything what's in /dev/VG directory should be visible (the only exceptions are thin-pool and cache-pool volumes).

It is possible to use "role" fields (see `lvs -o+role` output) to filter out any "private" devices (column matching perl-re `/(,|^)private(,|$)/` or using lvm's select: `lvs -S role=public`).

I checked at least mirror and RAID1 volumes work fine.
Looks it is only thin-volumes not present.

Version-Release number of selected component (if applicable):

libvirt-*-1.2.17-13.el7_2.5.x86_64

It is the same on F25:

libvirt-*-2.0.0-2.fc25.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Prepare the env:

    Create a Logical storage pool # You know better how to automate this...
    Let vg0 be both the name of the volume group and of the pool.

2. As root create a thin-pool and thin-volumes:

    #!/bin/bash

    # TODO: modify these as appropriate
    VG=vg0 # name of the VG from step 0.1
    POOL=pool1
    THINLV=thin
    LV=linear
    # choose whatever small size here, we will not continue with installation:
    SIZEOFPOOL=16M
    SIZEOFTHINVOL=16M
    SIZEOFVOL=16M

    # Create pool and thin-volumes (and regular one to check feature works at all)
    lvcreate --type thin --thin-pool $VG/$POOL -L $SIZEOFPOOL -n $THINLV -V $SIZEOFTHINVOL
    lvcreate -n $LV -L $SIZEOFVOL $VG

    # Refresh pool:
    virsh pool-refresh $VG

    # list volumes:
    virsh vol-list --pool $VG


Assuming THINLV is "thin" and LV is "linear":

Actual results:
Only the "linear" volume is present

Expected results:
Both "thin" and "linear" volumes should be there.

Comment 1 Ján Tomko 2016-08-03 14:52:17 UTC

*** This bug has been marked as a duplicate of bug 1060287 ***


Note You need to log in before you can comment on or make changes to this bug.