Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1363785 - otopi minidnf fails on fedora 24
Summary: otopi minidnf fails on fedora 24
Keywords:
Status: CLOSED DUPLICATE of bug 1363805
Alias: None
Product: Fedora
Classification: Fedora
Component: python
Version: 24
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Charalampos Stratakis
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-03 14:40 UTC by Sandro Bonazzola
Modified: 2016-08-03 15:36 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1363805 (view as bug list)
Environment:
Last Closed: 2016-08-03 15:36:35 UTC


Attachments (Terms of Use)
abrt-cli report (deleted)
2016-08-03 14:41 UTC, Sandro Bonazzola
no flags Details

Description Sandro Bonazzola 2016-08-03 14:40:27 UTC
Description of problem:
running a python application called engine-setup from oVirt project which relies on python bindings for dnf.

The python interpreter crashes and generates a coredump, see abrt report attached (didn't work automatically since the otopi package is not part of Fedora)

It's not caused by selinux denials:
# ausearch -m avc
<no matches>

It's 100% reproducible:
 # dnf install python2-dnf.noarch
 # dnf install http://resources.ovirt.org/pub/yum-repo/ovirt-release-master.rpm
 # dnf install ovirt-engine
 # engine-setup

On fedora 23 worked fine.

Comment 1 Sandro Bonazzola 2016-08-03 14:41:34 UTC
Created attachment 1187100 [details]
abrt-cli report

Comment 2 Yedidyah Bar David 2016-08-03 15:32:07 UTC
The attached stack trace has:

\#3  0x00007f69f50c9042 in __GI___assert_fail (assertion=0x7f69e2796727 "hrepo->state_main == _HY_NEW", file=0x7f69e2796538 "/builddir/build/BUILD/hawkey-0.6.3/src/sack.c"

\#9  PyEval_EvalFrameEx (f=f@entry=Frame 0x555c708d9670, for file /usr/lib/python2.7/site-packages/dnf/base.py, line 127, in _add_repo_to_sack

\#13 PyEval_EvalFrameEx (f=f@entry=Frame 0x555c70862720, for file /usr/lib/python2.7/site-packages/dnf/base.py, line 239, in fill_sack

\#17 PyEval_EvalFrameEx (f=f@entry=Frame 0x7f69deb31420, for file /usr/lib/python2.7/site-packages/otopi/minidnf.py, line 530, in clean 

Still not sure about the root cause, taking to otopi for now. Will move back to python/dnf/hawkey if relevant.

Comment 3 Yedidyah Bar David 2016-08-03 15:33:58 UTC
Can't take to otopi because bugzilla requires oVirt Team but does not allow setting one... Cloning.

Comment 4 Yedidyah Bar David 2016-08-03 15:36:35 UTC

*** This bug has been marked as a duplicate of bug 1363805 ***


Note You need to log in before you can comment on or make changes to this bug.