Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1363774 - Reset Automate Datastore text misleading
Summary: Reset Automate Datastore text misleading
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate
Version: 5.6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: GA
: 5.7.0
Assignee: Patrik Kománek
QA Contact: Milan Falešník
URL:
Whiteboard: automate
: 1373996 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-03 14:07 UTC by Christian Jung
Modified: 2017-03-16 10:32 UTC (History)
10 users (show)

Fixed In Version: 5.7.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-04 12:58:53 UTC
Category: ---
Cloudforms Team: CFME Core


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0012 normal SHIPPED_LIVE CFME 5.7.0 bug fixes and enhancement update 2017-01-04 17:50:36 UTC

Description Christian Jung 2016-08-03 14:07:10 UTC
Description of problem:
When you navigate to Automate, Import/Export you can click on "Reset all Datastore custom classes and instances to default" - although it says so, it only resets the ManageIQ and Red Hat domain and doesn't touch any custom domains.

This was true when we didn't have the multiple domains in very old versions. 

Version-Release number of selected component (if applicable):
5.6, but earlier versions too

How reproducible:
always

Steps to Reproduce:
1. navigate to Automate, Export/Import
2. Reset all Datastore custom classes and instances to default
3.

Actual results:
It actually doesn't reset the "custom classes", it only reset the ManageIQ and Red Hat Domains - it doesn't change anything on custom (aka. user created) domains.


Expected results:
The text should be less confusing

Additional info:
it's not obvious you have to click on the arror icon to actually perform this action. There should be an easy to identify button.

Comment 3 Greg McCullough 2016-08-04 15:11:26 UTC
Suggested change: "Reset all components in the following domains: XXX, YYY"

We will need a method in the MiqAeDatastore model to return the names which need to be read from the YAML files stored in fixtures/ae_datastore directory.

Comment 5 Greg McCullough 2016-08-08 13:11:20 UTC
Patrik - I would like to refactor the code in reset_to_defaults to create a new method that yields the domain_file.  This new method can then be used in reset_to_defaults as well as a new method that returns the Domain name that is stored in the domain_file (which is yaml).

The code I am referring to is here: https://github.com/ManageIQ/manageiq/blob/master/lib/miq_automation_engine/models/miq_ae_datastore.rb#L167

Comment 6 Patrik Kománek 2016-09-05 15:30:35 UTC
solved in PR: https://github.com/ManageIQ/manageiq/pull/10899

Comment 7 Greg McCullough 2016-09-07 17:30:04 UTC
*** Bug 1373996 has been marked as a duplicate of this bug. ***

Comment 8 Milan Falešník 2016-09-29 12:31:48 UTC
Verified in 5.7.0.1

The text is now more descriptive.

Comment 10 errata-xmlrpc 2017-01-04 12:58:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0012.html


Note You need to log in before you can comment on or make changes to this bug.