Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1363707 - launch-fusor-undercloud-installer incorrectly calculates RAM
Summary: launch-fusor-undercloud-installer incorrectly calculates RAM
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: Installation - RHELOSP
Version: 1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ga
: 1.0
Assignee: Derek Whatley
QA Contact: bmorriso
Julie
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-03 12:05 UTC by Thom Carlin
Modified: 2016-09-13 16:35 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-13 16:35:06 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1862 normal SHIPPED_LIVE Red Hat Quickstart Installer 1.0 2016-09-13 20:18:48 UTC

Description Thom Carlin 2016-08-03 12:05:04 UTC
Description of problem:

Insufficient ram error message in launch-fusor-undercloud-installer

Version-Release number of selected component (if applicable):

QCI-1.0-RHEL-7-20160801.t.2
QCIOOO-8.0-RHEL-7-20160801.t.0

How reproducible:

Believe 100%

Steps to Reproduce:
1. Install Triple-O
2. Log in to run launch-fusor-undercloud-installer
3.

Actual results:

Checking RAM size... 96 MB [FAILED]
16384 MB RAM required, 16384 MB recommended.
Proceed without meeting RAM requirement (y/n)?

Expected results:

Checking RAM size... 96 GB  [OK]

Additional info:

/proc/meminfo shows MemTotal: 98803532 Kb

dmidecode -t 17|grep Size:
Size: 32 GB
Size: 32 GB
Size: 32 GB

/usr/sbin/fusor-undercloud-installer lines 270 to 272 incorrectly assume memory is reported in MB.

This is a similar issue reported in ironic where I posted a fix

Comment 2 Derek Whatley 2016-08-08 18:31:21 UTC
Should be fixed in fusor-undercloud-installer: https://github.com/fusor/fusor-undercloud-installer/pull/48 . 

Now using 'free -m' instead of 'dmidecode -t 17'. dmidecode provides very different output on different hardware configurations.

Similar fix was implemented in fusor-installer as well: https://github.com/fusor/fusor-installer/pull/84.

Looks like changes were merged on Friday.

Comment 3 John Matthews 2016-08-08 21:58:00 UTC
Included in the 8/6 QCIOOO compose.

Comment 4 bmorriso 2016-08-19 19:40:32 UTC
Verified with QCIOOO-8.0-RHEL-7-20160815.t.3 on VM installation of undercloud ISO.

Available memory is correctly reported by launch-fusor-undercloud-installer.

Comment 6 errata-xmlrpc 2016-09-13 16:35:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862


Note You need to log in before you can comment on or make changes to this bug.