Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1363697 - RFE: Support Keepalived Notify Script in IP Failover Pod
Summary: RFE: Support Keepalived Notify Script in IP Failover Pod
Keywords:
Status: CLOSED DUPLICATE of bug 1362163
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: RFE
Version: 3.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Phil Cameron
QA Contact: Meng Bo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-03 11:51 UTC by Jaspreet Kaur
Modified: 2017-01-05 20:09 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-05 20:08:09 UTC


Attachments (Terms of Use)

Description Jaspreet Kaur 2016-08-03 11:51:38 UTC
1. What is the nature and description of the request?  

We'd like to see support for the Keepalived notify script script feature in the IP failover pod (See https://github.com/openshift/origin/tree/master/images/ipfailover/keepalived). For a description of this feature, see this blog post which describes it's use: https://tobrunet.ch/2013/07/keepalived-check-and-notify-scripts/

      
2. Why does the customer need this? (List the business requirements here)  

The use case for this feature would be to notify a cloud service for a floating IP change. Many clouds don't support VRRP for floating IPs, but have an API available which could be used by the notify script of Keepalived.
      
3. How would the customer like to achieve this? (List the functional requirements here)


To pass the script into the Pod it could be done over an environment variable (f.e. OPENSHIFT_HA_NOTIFY_SCRIPT) and then write it to a file in the Pod (just like the Keepalived configuration is done).

      
4. For each functional requirement listed, specify how Red Hat and the customer can test to confirm the requirement is successfully implemented.  

Yes

Comment 4 Phil Cameron 2017-01-05 20:08:09 UTC

*** This bug has been marked as a duplicate of bug 1362163 ***

Comment 5 Phil Cameron 2017-01-05 20:09:16 UTC
The code is in PR 11644
check script and notify script support were added at the same time.


Note You need to log in before you can comment on or make changes to this bug.