Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1363647 - Can't deploy on PostgreSQL 9.5.3
Summary: Can't deploy on PostgreSQL 9.5.3
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Candlepin
Classification: Community
Component: candlepin
Version: 2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: candlepin-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-03 09:30 UTC by Filip Nguyen
Modified: 2016-08-08 08:43 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-08 08:43:12 UTC


Attachments (Terms of Use)

Description Filip Nguyen 2016-08-03 09:30:21 UTC
Description of problem:
Cant deploy:
Caused by: org.hibernate.HibernateException: Wrong column type in public.cp2_content for column locked. Found: int2, expected: int4


Version-Release number of selected component (if applicable):

Fedora 24

PostgreSQL 9.5.3 on x86_64-redhat-linux-gnu, compiled by gcc (GCC) 6.0.0 20160406 (Red Hat 6.0.0-0.20), 64-bit

How reproducible:
always

Steps to Reproduce:
1. server/bin/deploy -g

Actual results:
Exception


Expected results:
No exception

Additional info:

Comment 1 Filip Nguyen 2016-08-08 08:43:12 UTC

The problem was in my candlepin.conf. It sets hbm2ddl.auto to validate, which forces Hibernate to check the data type

 #Old Satellite config
jpa.config.hibernate.hbm2ddl.auto=validate


Note You need to log in before you can comment on or make changes to this bug.