Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1363618 - When set disable-legacy=on and disable-modern=on,guest can't recognise this device.
Summary: When set disable-legacy=on and disable-modern=on,guest can't recognise this d...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.3
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: jason wang
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-03 08:18 UTC by weliao
Modified: 2016-08-23 07:18 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 07:18:13 UTC


Attachments (Terms of Use)

Description weliao 2016-08-03 08:18:28 UTC
Description of problem:
Launch a NIC with virtio1.0, then hot unplug this NIC, and hotplug a virtio0.95 NIC,guest can't recognise this device.

Version-Release number of selected component (if applicable):
Host:
qemu-kvm-rhev-2.6.0-17.el7.x86_64
3.10.0-481.el7.x86_64
Guest:
3.10.0-481.el7.x86_64
How reproducible:
100%

Steps to Reproduce:
1.Launch a Guest with virtio1.0 
-netdev tap,id=hostnet0,vhost=on,poll-us=3,vhost=off,queues=4   \
-device virtio-net-pci,netdev=hostnet0,id=net0,mac=52:54:01:ee:66:23,bus=pci.0,addr=0x4,disable-legacy=off,disable-modern=off,vectors=10,mq=on
2.hot unplug this device.
(qemu) device_del net0
3.hot plug a virtio0.95 device
(qemu)device_add virtio-net-pci,netdev=hostnet0,id=net0,mac=52:54:01:ee:66:23,bus=pci.0,addr=0x4,disable-legacy=on,disable-modern=on,vectors=10


Actual results:
in guest: ip link show
guest can't recognise this device.

Expected results:
Guest can recognise this device.

Additional info:
command:
/usr/libexec/qemu-kvm \
-name rhel7.3 -M pc \
-cpu SandyBridge \
-m 2048 -realtime mlock=off -nodefaults \
-smp 4 \
-device virtio-scsi-pci,id=scsi2,indirect_desc=off,event_idx=off,bus=pci.0,disable-legacy=off,disable-modern=off \
-drive file=/mnt/RHEL7_3.qcow2,if=none,id=drive-virtio-disk0,format=qcow2 \
-device scsi-hd,bus=scsi2.0,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1  \
-netdev tap,id=hostnet0,vhost=on,poll-us=3,vhost=off,queues=4   \
-device virtio-net-pci,netdev=hostnet0,id=net0,mac=52:54:01:ee:66:23,bus=pci.0,addr=0x4,disable-legacy=off,disable-modern=off,vectors=10,mq=on \
-vnc :1 -monitor stdio \
 -boot menu=on \
-qmp tcp:0:4446,server,nowait \
-vga cirrus

Comment 1 weliao 2016-08-03 09:50:28 UTC
Sorry, seem no relationship with virtio1.0 or virtio0.95, I retested it find because disable-legacy=on,disable-modern=on. when disable-legacy and disable-modern all set "on", will can't recognise the device.

Comment 3 Amnon Ilan 2016-08-08 16:05:36 UTC
This seems to make sense, when the device is not legacy and not modern it 
cannot communicate.. 
I guess the only problem is that there is no error message on that.
Jason, can you have a look?

Comment 4 jason wang 2016-08-23 07:18:13 UTC
Yes, I don't think disable-legacy=on,disable-modern=on can work. So close this first, feel free to reopen.


Note You need to log in before you can comment on or make changes to this bug.