Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1363600 - [abrt] WARNING: CPU: 2 PID: 16351 at kernel/irq/manage.c:1447 __free_irq+0xa4/0x290
Summary: [abrt] WARNING: CPU: 2 PID: 16351 at kernel/irq/manage.c:1447 __free_irq+0xa4...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 24
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:bf9d4aa1ff2c4a6510d3b153ae4...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-03 07:11 UTC by Michael Chapman
Modified: 2016-10-04 14:44 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-04 14:44:26 UTC


Attachments (Terms of Use)
File: dmesg (deleted)
2016-08-03 07:12 UTC, Michael Chapman
no flags Details

Description Michael Chapman 2016-08-03 07:11:51 UTC
Description of problem:
This error occurred while attempting to suspend the system.

Additional info:
reporter:       libreport-2.7.2
WARNING: CPU: 2 PID: 16351 at kernel/irq/manage.c:1447 __free_irq+0xa4/0x290
Trying to free already-free IRQ 20
Modules linked in: fuse ccm ip6t_REJECT nf_reject_ipv6 ip6t_rpfilter xt_conntrack ip_set nfnetlink ebtable_broute bridge stp llc ebtable_nat ip6table_security ip6table_mangle ip6table_raw ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 iptable_security iptable_mangle iptable_raw iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack ebtable_filter ebtables ip6table_filter ip6_tables vfat fat uvcvideo videobuf2_vmalloc videobuf2_memops iTCO_wdt iTCO_vendor_support videobuf2_v4l2 mei_wdt videobuf2_core videodev intel_rapl arc4 x86_pkg_temp_thermal snd_hda_codec_hdmi coretemp media iwldvm kvm_intel snd_hda_codec_realtek kvm snd_hda_codec_generic snd_usb_audio mac80211 snd_hda_intel irqbypass snd_hda_codec snd_usbmidi_lib iwlwifi snd_hda_core snd_hwdep cfg80211
 snd_rawmidi snd_seq joydev snd_seq_device snd_pcm i2c_i801 shpchp lpc_ich snd_timer mei_me mei wmi thinkpad_acpi snd soundcore rfkill tpm_tis nfsd auth_rpcgss binfmt_misc nfs_acl lockd grace sunrpc dm_crypt i915 crct10dif_pclmul crc32_pclmul crc32c_intel ghash_clmulni_intel i2c_algo_bit drm_kms_helper e1000e sdhci_pci serio_raw sdhci mmc_core drm uas ptp usb_storage pps_core fjes video tpm_rng tpm
CPU: 2 PID: 16351 Comm: kworker/u16:76 Not tainted 4.6.5-300.fc24.x86_64 #1
Hardware name: LENOVO 2359CTO/2359CTO, BIOS G4ET92WW (2.52 ) 02/01/2013
Workqueue: events_unbound async_run_entry_fn
 0000000000000086 00000000b0569be6 ffff8801078c7b90 ffffffff813dbcef
 ffff8801078c7be0 0000000000000000 ffff8801078c7bd0 ffffffff810a741b
 000005a700000001 0000000000000014 ffff88007fbcc000 0000000000000014
Call Trace:
 [<ffffffff813dbcef>] dump_stack+0x63/0x84
 [<ffffffff810a741b>] __warn+0xcb/0xf0
 [<ffffffff810a749f>] warn_slowpath_fmt+0x5f/0x80
 [<ffffffff81112fb7>] ? lock_timer_base.isra.22+0x57/0x70
 [<ffffffff81103344>] __free_irq+0xa4/0x290
 [<ffffffff811035b9>] free_irq+0x39/0x90
 [<ffffffffc0128b9a>] e1000_free_irq+0x6a/0x70 [e1000e]
 [<ffffffffc0133ebf>] e1000e_pm_freeze+0x7f/0xb0 [e1000e]
 [<ffffffffc0133f16>] e1000e_pm_suspend+0x26/0x40 [e1000e]
 [<ffffffff8142b618>] pci_pm_suspend+0x78/0x150
 [<ffffffff8142b5a0>] ? pci_pm_freeze+0xf0/0xf0
 [<ffffffff8152b1dd>] dpm_run_callback+0x4d/0x130
 [<ffffffff8152bf88>] __device_suspend+0x148/0x370
 [<ffffffff8152c1cf>] async_suspend+0x1f/0xa0
 [<ffffffff810c99aa>] async_run_entry_fn+0x4a/0x140
 [<ffffffff810c0d74>] process_one_work+0x184/0x440
 [<ffffffff810c107e>] worker_thread+0x4e/0x480
 [<ffffffff810c1030>] ? process_one_work+0x440/0x440
 [<ffffffff810c6f78>] kthread+0xd8/0xf0
 [<ffffffff817e1002>] ret_from_fork+0x22/0x40
 [<ffffffff810c6ea0>] ? kthread_worker_fn+0x180/0x180

Comment 1 Michael Chapman 2016-08-03 07:12:03 UTC
Created attachment 1186966 [details]
File: dmesg

Comment 2 Laura Abbott 2016-09-23 19:19:03 UTC
*********** MASS BUG UPDATE **************
 
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 24 kernel bugs.
 
Fedora 24 has now been rebased to 4.7.4-200.fc24.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 25, and are still experiencing this issue, please change the version to Fedora 25.
 
If you experience different issues, please open a new bug report for those.

Comment 3 Michael Chapman 2016-10-04 00:40:01 UTC
I only hit this bug once, and I haven't since been able to reproduce it.

Feel free to close this ticket. I can reopen it if the problem ever comes back.


Note You need to log in before you can comment on or make changes to this bug.