Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1363598 - File not found errors during rpmbuild: /var/lib/glusterd/hooks/1/delete/post/S57glusterfind-delete-post.py{c,o}
Summary: File not found errors during rpmbuild: /var/lib/glusterd/hooks/1/delete/post/...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: packaging
Version: 3.8.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Oleksandr Natalenko
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-03 07:08 UTC by Oleksandr Natalenko
Modified: 2016-08-12 09:48 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.8.2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-12 09:48:35 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Oleksandr Natalenko 2016-08-03 07:08:58 UTC
Backport of 1356868 fix for 3.8.

Description of problem:

RPM build errors:
    File not found: /builddir/build/BUILDROOT/glusterfs-3.9dev-0.262.git203f952.el7.centos.x86_64/var/lib/glusterd/hooks/1/delete/post/S57glusterfind-delete-post.pyc
    File not found: /builddir/build/BUILDROOT/glusterfs-3.9dev-0.262.git203f952.el7.centos.x86_64/var/lib/glusterd/hooks/1/delete/post/S57glusterfind-delete-post.pyo

Comment 1 Vijay Bellur 2016-08-03 07:09:55 UTC
REVIEW: http://review.gluster.org/15075 (packaging: Remove ".py" extension from symlink target) posted (#1) for review on release-3.8 by Oleksandr Natalenko (oleksandr@natalenko.name)

Comment 2 Vijay Bellur 2016-08-03 07:52:25 UTC
REVIEW: http://review.gluster.org/15075 (packaging: Remove ".py" extension from symlink target) posted (#2) for review on release-3.8 by Oleksandr Natalenko (oleksandr@natalenko.name)

Comment 3 Vijay Bellur 2016-08-04 09:40:47 UTC
COMMIT: http://review.gluster.org/15075 committed in release-3.8 by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 15e83bedbef360fea0ff67eab4ac8a8a8dd17772
Author: Aravinda VK <avishwan@redhat.com>
Date:   Fri Jul 15 13:15:21 2016 +0530

    packaging: Remove ".py" extension from symlink target
    
    S57glusterfind-delete-post.py* is packaged in
    $LIBEXEC/glusterfs/glusterfind directory, symlink created to
    /var/lib/glusterd/hooks directory
    
    ln -s $(libexecdir)/glusterfs/glusterfind/S57glusterfind-delete-post.py \
    $(DESTDIR)$(GLUSTERD_WORKDIR)/hooks/1/delete/post/S57glusterfind-delete-post.py
    
    ".py" should be removed from symlink target so that build system will
    not try to compile the symlink files and generate .pyc/.pyo files.
    
    > Reviewed-on: http://review.gluster.org/14928
    > Smoke: Gluster Build System <jenkins@build.gluster.org>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > Reviewed-by: Kotresh HR <khiremat@redhat.com>
    > Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    
    Change-Id: I9155378aa72eb8559ba8af76d91a4985f69f38f9
    BUG: 1363598
    Signed-off-by: Aravinda VK <avishwan@redhat.com>
    Signed-off-by: Oleksandr Natalenko <oleksandr@natalenko.name>
    Reviewed-on: http://review.gluster.org/15075
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>

Comment 4 Niels de Vos 2016-08-12 09:48:35 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.2, please open a new bug report.

glusterfs-3.8.2 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/announce/2016-August/000058.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.