Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1363593 - Adding ISCSI target fail in cockpit storage page
Summary: Adding ISCSI target fail in cockpit storage page
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: ovirt-node
Classification: oVirt
Component: UI
Version: 4.0
Hardware: Unspecified
OS: Unspecified
medium
high vote
Target Milestone: ovirt-4.1.0-alpha
: ---
Assignee: Ryan Barry
QA Contact: Wei Wang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-03 06:58 UTC by Wei Wang
Modified: 2016-08-17 09:18 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-17 09:18:37 UTC
oVirt Team: Node
fdeutsch: ovirt-4.1?
rule-engine: planning_ack?
rule-engine: devel_ack?
ycui: testing_ack+


Attachments (Terms of Use)
ks file (deleted)
2016-08-03 06:58 UTC, Wei Wang
no flags Details
picture (deleted)
2016-08-03 06:59 UTC, Wei Wang
no flags Details
log files (deleted)
2016-08-03 06:59 UTC, Wei Wang
no flags Details

Description Wei Wang 2016-08-03 06:58:36 UTC
Created attachment 1186961 [details]
ks file

Description of problem:
Add ISCSI target fail in cockpit storage page.

Version-Release number of selected component (if applicable):
redhat-virtualization-host-4.0-20160727.1.x86_64
imgbased-0.7.3-0.1.el7ev.noarch
cockpit-0.114-2.el7.x86_64
cockpit-ovirt-dashboard-0.10.6-1.3.3.el7ev.noarch


How reproducible:
100%


Steps to Reproduce:
1. Install redhat-virtualization-host-4.0-20160727.1.x86_64 with kickstart file in attachment on iscsi machine
2. Login cockpit website hostIP:9090 with root account
3. Select "Storage" page
4. Click "Add" button in "iSCSI Targets" component 
5. Input right server address, then clicking "Next" button
6. Select one target from the targets list, then click "Add" button.

Actual results:
Add ISCSI target fail in cockpit storage page, login failed message is prompted.


Expected results:
The iscsi target should be added successfully.


Additional info:
I can login iscsi target from node console shell
[root@dhcp-xx-xxx /]# iscsiadm -m discovery -t st -p 10.73.194.25:3260
10.73.194.25:3260,1000 iqn.1992-08.com.netapp:sn.135053389
10.73.194.26:3260,1001 iqn.1992-08.com.netapp:sn.135053389
[root@dhcp-xx-xxx /]# iscsiadm -m node -l -T iqn.1992-08.com.netapp:sn.135053389 -p 10.73.194.25:3260
Logging in to [iface: default, target: iqn.1992-08.com.netapp:sn.135053389, portal: 10.73.194.25,3260] (multiple)
Login to [iface: default, target: iqn.1992-08.com.netapp:sn.135053389, portal: 10.73.194.25,3260] successful.
[root@dhcp-xx-xxx /]# iscsiadm -m node -u -T iqn.1992-08.com.netapp:sn.135053389 -p 10.73.194.25:3260
Logging out of session [sid: 7, target: iqn.1992-08.com.netapp:sn.135053389, portal: 10.73.194.25,3260]
Logout of [sid: 7, target: iqn.1992-08.com.netapp:sn.135053389, portal: 10.73.194.25,3260] successful.
[root@dhcp-xx-xxx /]# iscsiadm -m node -l -T iqn.1992-08.com.netapp:sn.135053389 -p 10.73.194.25:3260
Logging in to [iface: default, target: iqn.1992-08.com.netapp:sn.135053389, portal: 10.73.194.25,3260] (multiple)
Login to [iface: default, target: iqn.1992-08.com.netapp:sn.135053389, portal: 10.73.194.25,3260] successful.
[root@dhcp-xx-xxx /]# iscsiadm -m node -u -T iqn.1992-08.com.netapp:sn.135053389 -p 10.73.194.25:3260
Logging out of session [sid: 8, target: iqn.1992-08.com.netapp:sn.135053389, portal: 10.73.194.25,3260]
Logout of [sid: 8, target: iqn.1992-08.com.netapp:sn.135053389, portal: 10.73.194.25,3260] successful.

Comment 1 Wei Wang 2016-08-03 06:59:09 UTC
Created attachment 1186963 [details]
picture

Comment 2 Wei Wang 2016-08-03 06:59:41 UTC
Created attachment 1186964 [details]
log files

Comment 3 Fabian Deutsch 2016-08-03 11:01:17 UTC
The error in the screenshot from comment 1 does not look unreasonable.

Was there maybe already a session open to that specific target?

Comment 4 Ying Cui 2016-08-04 12:50:17 UTC
I did not see somewhere to show the issue happened sometimes, so I updated the bug summary.

Comment 5 Yihui Zhao 2016-08-17 07:59:04 UTC
Hello all,
  i add the iscsi targets successfully on the cockpit and list them on the "drive".

Version-Release number of selected component (if applicable):
redhat-virtualization-host-4.0-20160816.0.x86_64
imgbased-0.8.4-1.el7ev.noarch
cockpit-0.114-2.el7.x86_64
cockpit-ovirt-dashboard-0.10.6-1.3.6.el7ev.noarch

Thank you.
Yihui Zhao

Comment 6 cshao 2016-08-17 09:18:37 UTC
(In reply to Yihui Zhao from comment #5)
> Hello all,
>   i add the iscsi targets successfully on the cockpit and list them on the
> "drive".
> 
> Version-Release number of selected component (if applicable):
> redhat-virtualization-host-4.0-20160816.0.x86_64
> imgbased-0.8.4-1.el7ev.noarch
> cockpit-0.114-2.el7.x86_64
> cockpit-ovirt-dashboard-0.10.6-1.3.6.el7ev.noarch
> 
> Thank you.
> Yihui Zhao

Thanks for yzhao's update, due to add iscsi targets can successful on the cockpit with the latest build, so close this bug as WORKSFORME.


Note You need to log in before you can comment on or make changes to this bug.