Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1363589 - br-vlan(tunnel) was not created in the compute node with packstack deplyment
Summary: br-vlan(tunnel) was not created in the compute node with packstack deplyment
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Ivan Chavero
QA Contact: nlevinki
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-03 06:43 UTC by Eran Kuris
Modified: 2016-08-11 02:23 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-11 02:23:40 UTC


Attachments (Terms of Use)
answer file (deleted)
2016-08-07 09:19 UTC, Eran Kuris
no flags Details

Description Eran Kuris 2016-08-03 06:43:08 UTC
Description of problem:
I'm trying to deploy packstack, on 2 baremetal's, controller and compute
I'm using this job : https://rhos-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/view/All/job/qe-packstack-rhel-7.2-baremetal-ipv4-vlan-sriov/
to deploy sriov setup .
after the deployment ends, with successful message, the openvswitch on the compute node shows:
[root@compute ~]# ovs-vsctl show
1431f3dd-f564-4eb6-9451-d57bd216abe0
    Bridge br-int
        fail_mode: secure
        Port br-int
            Interface br-int
                type: internal
    ovs_version: "2.4.0"


the br-vlan(tunnel) was not created in the compute node.


log of the job : 
https://rhos-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/view/All/job/qe-packstack-rhel-7.2-baremetal-ipv4-vlan-sriov/35/console

Version-Release number of selected component (if applicable):

root@puma53 ~(keystone_admin)]# rpm -qa |grep packstack
openstack-packstack-puppet-8.0.0-0.20160725225443.5ab08f3.1.el7ost.noarch
openstack-packstack-8.0.0-0.20160725225443.5ab08f3.1.el7ost.noarch
[root@puma53 ~(keystone_admin)]# rpm -qa |grep openvswitch
openvswitch-2.5.0-3.el7.x86_64
openstack-neutron-openvswitch-9.0.0-0.20160726001729.6a23add.el7ost.noarch
python-openvswitch-2.5.0-3.el7.noarch
[root@puma53 ~(keystone_admin)]# rpm -qa |grep neutron 
python-neutron-lib-0.2.1-0.20160726025313.405f896.el7ost.noarch
openstack-neutron-lbaas-9.0.0-0.20160722053816.0c73910.el7ost.noarch
openstack-neutron-ml2-9.0.0-0.20160726001729.6a23add.el7ost.noarch
python-neutronclient-4.2.1-0.20160721230146.3b1c538.el7ost.noarch
openstack-neutron-common-9.0.0-0.20160726001729.6a23add.el7ost.noarch
openstack-neutron-9.0.0-0.20160726001729.6a23add.el7ost.noarch
python-neutron-9.0.0-0.20160726001729.6a23add.el7ost.noarch
openstack-neutron-fwaas-9.0.0-0.20160720211704.c3e491c.el7ost.noarch
openstack-neutron-metering-agent-9.0.0-0.20160726001729.6a23add.el7ost.noarch
openstack-neutron-openvswitch-9.0.0-0.20160726001729.6a23add.el7ost.noarch
python-neutron-fwaas-9.0.0-0.20160720211704.c3e491c.el7ost.noarch
puppet-neutron-9.1.0-0.20160725142451.4061b39.el7ost.noarch
python-neutron-lbaas-9.0.0-0.20160722053816.0c73910.el7ost.noarch
How reproducible:
always 

Steps to Reproduce:
1.use the jenkins job to deploy sriov setup with one controller &  1 compute 
2.after installation successful check:
ovs-vsctl show in both nodes 
3.

Actual results:
no br-vlan bridge in compute node.

Expected results:


Additional info:

Comment 2 Ivan Chavero 2016-08-05 01:19:55 UTC
Can you provide the answer file?
I'm not that familiar with this setup. Can you explain why that other bridge is needed in the compute node?

Comment 3 Eran Kuris 2016-08-07 09:19:30 UTC
Created attachment 1188355 [details]
answer file

Comment 4 Eran Kuris 2016-08-07 13:29:06 UTC
Ivan if you want  I have setup  that you can take a look on it . 
do you want the details ?

Comment 5 Ivan Chavero 2016-08-08 17:22:59 UTC
If you can give me access it would be great, thanks

Comment 6 Eran Kuris 2016-08-09 06:01:11 UTC
Please contact via IRC I will give you all details of the setup

Comment 7 Eran Kuris 2016-08-09 06:01:26 UTC
Please contact via IRC I will give you all details of the setup

Comment 8 Ivan Chavero 2016-08-11 02:23:40 UTC
I've found in your answer file that CONFIG_NEUTRON_OVS_BRIDGES_COMPUTE does not
have a value, that's the reason why the bridge is not being created on the
compute node.

# grep CONFIG_NEUTRON_OVS_BRIDGES_COMPUTE packstack_config.txt
CONFIG_NEUTRON_OVS_BRIDGES_COMPUTE=

it should be:

CONFIG_NEUTRON_OVS_BRIDGES_COMPUTE=br-vlan

I hope this helps.
I've closed the bug but if you have any other problem don't hesitate
to contact me or reopen the bug.


Note You need to log in before you can comment on or make changes to this bug.