Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1363578 - fuse/lock: deprecate fuse_migrate_locks
Summary: fuse/lock: deprecate fuse_migrate_locks
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: fuse
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Susant Kumar Palai
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-03 06:10 UTC by Susant Kumar Palai
Modified: 2018-08-29 03:37 UTC (History)
1 user (show)

Fixed In Version: glusterfs-4.1.3 (or later)
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-29 03:37:22 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Susant Kumar Palai 2016-08-03 06:10:45 UTC
Description of problem:
After patch: http://review.gluster.org/#/c/13901/, there won't be necessity to do fuse lock migration since, client identification can be done via CTX-ID.

Fuse_migrate_locks used to update the new fd and client information on existing locks in the lock translator. These updates wont be necessary anymore, hence the fuse locks migration needs to be removed


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Vijay Bellur 2016-08-03 07:11:40 UTC
REVIEW: http://review.gluster.org/15076 (fuse/lock/fd-migration: deprecate fuse-fd-migration) posted (#1) for review on master by Susant Palai (spalai@redhat.com)

Comment 2 Worker Ant 2016-09-14 07:41:03 UTC
REVIEW: http://review.gluster.org/15076 (fuse/lock/fd-migration: deprecate fuse-fd-migration) posted (#2) for review on master by Susant Palai (spalai@redhat.com)

Comment 3 Worker Ant 2016-09-20 08:39:31 UTC
REVIEW: http://review.gluster.org/15076 (fuse/lock/fd-migration: deprecate fuse-fd-migration) posted (#3) for review on master by Susant Palai (spalai@redhat.com)

Comment 4 Worker Ant 2016-09-20 12:56:37 UTC
REVIEW: http://review.gluster.org/15076 (fuse/lock/fd-migration: deprecate fuse-fd-migration) posted (#4) for review on master by Susant Palai (spalai@redhat.com)

Comment 5 Amar Tumballi 2018-08-29 03:37:22 UTC
This update is done in bulk based on the state of the patch and the time since last activity. If the issue is still seen, please reopen the bug.


Note You need to log in before you can comment on or make changes to this bug.