Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1362736 - sleeping function called from invalid context at mm/slab.h:393
Summary: sleeping function called from invalid context at mm/slab.h:393
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 24
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-03 03:47 UTC by George R. Goffe
Modified: 2016-10-06 18:03 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-06 18:03:50 UTC


Attachments (Terms of Use)
flat file copy of /var/log/messages (deleted)
2016-08-03 03:47 UTC, George R. Goffe
no flags Details

Description George R. Goffe 2016-08-03 03:47:45 UTC
Created attachment 1186933 [details]
flat file copy of /var/log/messages

Description of problem:

Receiving message "BUG: sleeping function called from invalid context at mm/slab.h:393" appears along with a stack trace on FC 24 x86_64 system 18 times between 18:30:06 and 18:30:07 during boot for the past 2-3 weeks.

Version-Release number of selected component (if applicable):

kernel-4.8.0-0.rc0.git3.1.fc26.x86_64

How reproducible:

readily

Steps to Reproduce:
1.unknown
2.
3.

Actual results:


Expected results:


Additional info:


    337 Aug  2 18:27:51 localhost systemd: Starting Create list of required static device nodes for the current kernel...
    338 Aug  2 18:27:51 localhost systemd: Starting Load Kernel Modules...
    339 Aug  2 18:27:51 localhost systemd: Starting dracut cmdline hook...
    340 Aug  2 18:27:51 localhost kernel: BUG: sleeping function called from invalid context at mm/slab.h:393
    341 Aug  2 18:27:51 localhost kernel: in_atomic(): 1, irqs_disabled(): 0, pid: 174, name: systemd-modules
    342 Aug  2 18:27:51 localhost kernel: no locks held by systemd-modules/174.
    343 Aug  2 18:27:51 localhost kernel: CPU: 1 PID: 174 Comm: systemd-modules Not tainted 4.8.0-0.rc0.git3.1.fc26.x86_64 #1
    344 Aug  2 18:27:51 localhost kernel: Hardware name: innotek GmbH VirtualBox/VirtualBox, BIOS VirtualBox 12/01/2006
    345 Aug  2 18:27:51 localhost kernel:  0000000000000286 00000000f78e6d10 ffff96cbb35a7900 ffffffff8d464fd3
    346 Aug  2 18:27:51 localhost kernel:  ffff96cbb3918000 ffffffff8dc7d01c ffff96cbb35a7928 ffffffff8d0de759
    347 Aug  2 18:27:51 localhost kernel:  ffffffff8dc7d01c 0000000000000189 0000000000000000 ffff96cbb35a7950
    348 Aug  2 18:27:51 localhost kernel: Call Trace:
    349 Aug  2 18:27:51 localhost kernel:  [<ffffffff8d464fd3>] dump_stack+0x86/0xc3
    350 Aug  2 18:27:51 localhost kernel:  [<ffffffff8d0de759>] ___might_sleep+0x179/0x230
    351 Aug  2 18:27:51 localhost kernel:  [<ffffffff8d0de859>] __might_sleep+0x49/0x80
    352 Aug  2 18:27:51 localhost kernel:  [<ffffffff8d2700d6>] kmem_cache_alloc_trace+0x1e6/0x2d0
    353 Aug  2 18:27:51 localhost kernel:  [<ffffffff8d49db10>] ? mpi_alloc+0x20/0x80
    354 Aug  2 18:27:51 localhost kernel:  [<ffffffff8d49db10>] mpi_alloc+0x20/0x80
    355 Aug  2 18:27:51 localhost kernel:  [<ffffffff8d49b465>] mpi_read_raw_from_sgl+0xd5/0x1e0
    356 Aug  2 18:27:51 localhost kernel:  [<ffffffff8d404746>] rsa_verify+0x66/0x100
    357 Aug  2 18:27:51 localhost kernel:  [<ffffffff8d271d35>] ? __kmalloc+0x2e5/0x320
    358 Aug  2 18:27:51 localhost kernel:  [<ffffffff8d405b99>] pkcs1pad_verify+0x149/0x190
    359 Aug  2 18:27:51 localhost kernel:  [<ffffffff8d420459>] public_key_verify_signature+0x1f9/0x290
    360 Aug  2 18:27:51 localhost kernel:  [<ffffffff8d420505>] public_key_verify_signature_2+0x15/0x20
    361 Aug  2 18:27:51 localhost kernel:  [<ffffffff8d42015c>] verify_signature+0x3c/0x50
    362 Aug  2 18:27:51 localhost kernel:  [<ffffffff8d4223cd>] pkcs7_validate_trust+0x11d/0x230
    363 Aug  2 18:27:51 localhost kernel:  [<ffffffff8d1f51eb>] verify_pkcs7_signature+0xbb/0x180
    364 Aug  2 18:27:51 localhost kernel:  [<ffffffff8d15c23d>] mod_verify_sig+0xdd/0x130
    365 Aug  2 18:27:51 localhost kernel:  [<ffffffff8d158f7c>] load_module+0x16c/0x2960
    366 Aug  2 18:27:51 localhost kernel:  [<ffffffff8d24b17c>] ? vmap_page_range_noflush+0x25c/0x360
    367 Aug  2 18:27:51 localhost kernel:  [<ffffffff8d235c33>] ? __might_fault+0x43/0xa0
    368 Aug  2 18:27:51 localhost kernel:  [<ffffffff8d068565>] ? kvm_sched_clock_read+0x25/0x40
    369 Aug  2 18:27:51 localhost kernel:  [<ffffffff8d037e89>] ? sched_clock+0x9/0x10
    370 Aug  2 18:27:51 localhost kernel:  [<ffffffff8d0ea417>] ? sched_clock_cpu+0xa7/0xc0
    371 Aug  2 18:27:51 localhost kernel:  [<ffffffff8d235c33>] ? __might_fault+0x43/0xa0
    372 Aug  2 18:27:51 localhost kernel:  [<ffffffff8d235c33>] ? __might_fault+0x43/0xa0
    373 Aug  2 18:27:51 localhost kernel:  [<ffffffff8d15b8e2>] SYSC_init_module+0x172/0x1b0
    374 Aug  2 18:27:51 localhost kernel:  [<ffffffff8d15ba4e>] SyS_init_module+0xe/0x10
    375 Aug  2 18:27:51 localhost kernel:  [<ffffffff8d8f283c>] entry_SYSCALL_64_fastpath+0x1f/0xbd
    376 Aug  2 18:27:51 localhost systemd: Starting Journal Service...
    377 Aug  2 18:27:51 localhost systemd: Reached target Timers.
    378 Aug  2 18:27:51 localhost systemd: Listening on udev Control Socket.
    379 Aug  2 18:27:51 localhost kernel: i2c /dev entries driver

Comment 1 George R. Goffe 2016-08-06 16:44:59 UTC
Hi,

Can "we" get someone to take a least a peek at this bug please?

George...

Comment 2 Laura Abbott 2016-09-23 19:17:59 UTC
*********** MASS BUG UPDATE **************
 
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 24 kernel bugs.
 
Fedora 24 has now been rebased to 4.7.4-200.fc24.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 25, and are still experiencing this issue, please change the version to Fedora 25.
 
If you experience different issues, please open a new bug report for those.

Comment 3 George R. Goffe 2016-10-06 17:13:41 UTC
Laura,

This bug seems to have gone away.

Close it?

Thanks,

George


Note You need to log in before you can comment on or make changes to this bug.