Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1362718 - <ns0:check-import/> node contains bogus bytes
Summary: <ns0:check-import/> node contains bogus bytes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: preupgrade-assistant
Version: 6.8
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Michal Bocek
QA Contact: Alois Mahdal
URL:
Whiteboard:
Depends On:
Blocks: 1429926
TreeView+ depends on / blocked
 
Reported: 2016-08-03 00:27 UTC by Alois Mahdal
Modified: 2017-11-14 20:40 UTC (History)
6 users (show)

Fixed In Version: preupgrade-assistant-2.5.0-1.el6
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2017-11-14 20:40:21 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:3211 normal SHIPPED_LIVE preupgrade-assistant bug fix and enhancement update 2017-11-15 01:23:07 UTC
Github upgrades-migrations preupgrade-assistant pull 221 None None None 2017-11-01 16:36:44 UTC

Description Alois Mahdal 2016-08-03 00:27:11 UTC
Description of problem
======================

Even if there was no standard error from module check script, result.xml
will still contain data.

Following example is prefixed with '|' to denote start of line:

    |        <ns0:check-import import-name="stderr">
    |          </ns0:check-import>

Here, the relevant node contains following bytes:

    0a:20:20:20:20:20:20:20:20:20:20

Even though it's just whitespace, it's incorrect and prevents reliably
detecting *actual* error output.


Version-Release number of selected component
============================================

preupgrade-assistant-2.1.8-2.el6


How reproducible
================

Always


Steps to Reproduce
==================

 1. Run preupg with module(s) that don't print anything
 2. Observe `<ns0:check-import/>` nodes in result.xml
    (there may be other relevant nodes, see note below)


Actual results
==============

All should be empty


Expected results
================

Currently, at least `import-name="stderr"` contains whitespace.


Additional info
===============

Note that currently due to bug 1309491, it's actually impossible for the
node mentioned above to contain *any* data; this will remain even after
the fix but in future openscap version, new nodes will be added which
will be relevant to stdout/stderr and this bug.

Comment 3 Michal Bocek 2017-10-11 14:36:23 UTC
Fixed in upstream: https://github.com/upgrades-migrations/preupgrade-assistant/pull/221

Comment 5 Alois Mahdal 2017-10-18 16:57:00 UTC
Notes for QE
============

Test suite contains workaround for this (search for bug number), so removing it and not seeing failures should suffice.

Note that the mentioned PR221 makes several arbitrary changes independent of this bug and it has not been confirmed that the 'extra space' part of it really is the very same problem as this bug has reported (it does look very similar but I remember I did have doubts, not sure why).

Comment 6 Alois Mahdal 2017-11-03 19:20:45 UTC
Removed the workaround and re-ran tests.  Looks fine; bogus whitespace is removed.

Comment 8 errata-xmlrpc 2017-11-14 20:40:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3211


Note You need to log in before you can comment on or make changes to this bug.