Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1362712 - Persistent volume claims get stuck in pending.
Summary: Persistent volume claims get stuck in pending.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Storage
Version: 3.x
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: ---
Assignee: Jan Safranek
QA Contact: mdong
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-02 23:52 UTC by Graham Dumpleton
Modified: 2016-09-20 04:48 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-09 13:45:46 UTC


Attachments (Terms of Use)

Description Graham Dumpleton 2016-08-02 23:52:17 UTC
Description of problem:

Persistent volume claims are not being granted. Permanently stay in pending.

$ oc get pvc
NAME      STATUS    VOLUME    CAPACITY   ACCESSMODES   AGE
mongodb   Pending                                      1h

Version-Release number of selected component (if applicable):

Online Developer Preview environment.

OpenShift Master:
v3.2.1.10-1-g668ed0a
Kubernetes Master:
v1.2.0-36-g4a3f9c5

How reproducible:

Failed three times in a row when trying to deploy MongoDB from web interface. The volume claims were deleted between each attempt and were shown as removed.

Steps to Reproduce:

Try deploying MongoDB.

Actual results:

Persistent volume claim stuck in pending.

Expected results:

Persistent volume claim should be granted, allowing deployment of MongoDB to complete.

Comment 1 Jan Safranek 2016-08-08 15:56:53 UTC
Can you please share your PVC, pod and replication controllers definitions (i.e. the yaml files) + output of "oc describe pvc"?

Logs from openshift master would help too, if you have access to OpenShift online.

Comment 2 Graham Dumpleton 2016-08-08 19:38:35 UTC
It was a deployment using the standard MongoDB template in the online preview environment. You can see from that whatever resources it was creating.

As this is the online preview environment, users like me do not have admin access to the environment.

As this has been a week since the event, and it was an operational issue, there is probably no point given it was likely transient.

The issue is probably just part of the various problems the environment has had over the past week and finally flagged on the status page at the end of last week.

http://status.preview.openshift.com

Comment 3 Mark Turansky 2016-08-08 21:04:52 UTC
Reproducing this error today in whichever environment would be helpful.

Comment 4 Graham Dumpleton 2016-08-09 00:00:18 UTC
It is not reproducible at the moment and really need to have been looked at at the time. You may as well close this report and if happens again will find another way to bring it to attention to operations people for the online preview cluster so details can be captured straight away. Thanks.

Comment 5 Mark Turansky 2016-08-09 13:45:46 UTC
Closing per Graham's comment above.


Note You need to log in before you can comment on or make changes to this bug.