Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1362708 - preupg --list-rules does not respect --contents
Summary: preupg --list-rules does not respect --contents
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: preupgrade-assistant
Version: 6.8
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Michal Bocek
QA Contact: Alois Mahdal
Jiri Hornicek
URL:
Whiteboard:
: 1362709 (view as bug list)
Depends On:
Blocks: 1429926
TreeView+ depends on / blocked
 
Reported: 2016-08-02 23:07 UTC by Alois Mahdal
Modified: 2017-11-14 20:40 UTC (History)
5 users (show)

Fixed In Version: preupgrade-assistant-2.5.1-1.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-14 20:40:21 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:3211 normal SHIPPED_LIVE preupgrade-assistant bug fix and enhancement update 2017-11-15 01:23:07 UTC
Github upgrades-migrations preupgrade-assistant pull 330 None None None 2017-11-01 17:22:08 UTC

Description Alois Mahdal 2016-08-02 23:07:19 UTC
Description of problem
======================

When using preupg with a custom-generated upgrade path (using
preupg-xccdf-compose), the `--list-rules` command will not respect
`--contents` parameter

Instead; you'll get list of modules installed under /usr (--contents
is ignored).


Version-Release number of selected component
============================================

preupgrade-assistant-2.1.8-2.el6


How reproducible
================

Always


Steps to Reproduce
==================

 1. generate few modules usinf preupg-content-creator (provide
    same upgrade path name, ie. the first parameter)

 2. compile using `preupg-xccdf-compose DIR` (DIR will be same
    as the upgrade path name)

 3. `preupg --contents DIR/all-xccdf.xml --list-rules`


Actual results
==============

You get list of rules installed under /usr (if any)


Expected results
================

List of just-created rules

Comment 2 Alois Mahdal 2016-08-03 01:19:57 UTC
*** Bug 1362709 has been marked as a duplicate of this bug. ***

Comment 5 Alois Mahdal 2017-11-10 14:47:07 UTC
Re-tested with /errata/prepare + latest build and passed.

Comment 7 errata-xmlrpc 2017-11-14 20:40:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3211


Note You need to log in before you can comment on or make changes to this bug.