Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1362686 - RHEL 5 Content hosts are unable to set/list releases from subscription-manager
Summary: RHEL 5 Content hosts are unable to set/list releases from subscription-manager
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Candlepin
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: Unspecified
Assignee: Barnaby Court
QA Contact: Katello QA List
URL:
Whiteboard:
: 1241572 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-02 20:59 UTC by Craig Donnelly
Modified: 2018-03-27 17:44 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-27 17:44:59 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1241572 None CLOSED subscription-manager is expecting a "release" value in the api call to status 2019-04-10 15:08:30 UTC

Internal Links: 1241572

Description Craig Donnelly 2016-08-02 20:59:44 UTC
Description of problem:
Attempting to list or set a release version on RHEL 5.11 results in a traceback on Satellite 6.2

==> /var/log/foreman/production.log <==
2016-08-02 16:50:38 [app] [I] Completed 200 OK in 131ms (Views: 3.3ms | ActiveRecord: 1.3ms)
2016-08-02 16:50:38 [app] [I] Started GET "/Default_Organization/Library/content/dist/rhel/server/5//listing" for 10.12.214.0 at 2016-08-02 16:50:38 -0400
2016-08-02 16:50:38 [app] [F] 
 | ActionController::RoutingError (No route matches [GET] "/Default_Organization/Library/content/dist/rhel/server/5/listing"):
 |   actionpack (4.1.5) lib/action_dispatch/middleware/debug_exceptions.rb:21:in `call'
 |   actionpack (4.1.5) lib/action_dispatch/middleware/show_exceptions.rb:30:in `call'
 |   railties (4.1.5) lib/rails/rack/logger.rb:38:in `call_app'
 |   railties (4.1.5) lib/rails/rack/logger.rb:22:in `call'
 |   actionpack (4.1.5) lib/action_dispatch/middleware/request_id.rb:21:in `call'
 |   rack (1.5.2) lib/rack/methodoverride.rb:21:in `call'
 |   rack (1.5.2) lib/rack/runtime.rb:17:in `call'
 |   activesupport (4.1.5) lib/active_support/cache/strategy/local_cache_middleware.rb:26:in `call'
 |   actionpack (4.1.5) lib/action_dispatch/middleware/static.rb:64:in `call'
 |   actionpack (4.1.5) lib/action_dispatch/middleware/static.rb:64:in `call'
 |   rack (1.5.2) lib/rack/sendfile.rb:112:in `call'
 |   railties (4.1.5) lib/rails/engine.rb:514:in `call'
 |   railties (4.1.5) lib/rails/application.rb:144:in `call'
 |   railties (4.1.5) lib/rails/railtie.rb:194:in `public_send'
 |   railties (4.1.5) lib/rails/railtie.rb:194:in `method_missing'
 |   rack (1.5.2) lib/rack/builder.rb:138:in `call'
 |   rack (1.5.2) lib/rack/urlmap.rb:65:in `block in call'
 |   rack (1.5.2) lib/rack/urlmap.rb:50:in `each'
 |   rack (1.5.2) lib/rack/urlmap.rb:50:in `call'
 |   /usr/share/gems/gems/passenger-4.0.18/lib/phusion_passenger/rack/thread_handler_extension.rb:77:in `process_request'
 |   /usr/share/gems/gems/passenger-4.0.18/lib/phusion_passenger/request_handler/thread_handler.rb:140:in `accept_and_process_next_request'
 |   /usr/share/gems/gems/passenger-4.0.18/lib/phusion_passenger/request_handler/thread_handler.rb:108:in `main_loop'
 |   /usr/share/gems/gems/passenger-4.0.18/lib/phusion_passenger/request_handler.rb:441:in `block (3 levels) in start_threads'
 |   logging (1.8.2) lib/logging/diagnostic_context.rb:323:in `call'
 |   logging (1.8.2) lib/logging/diagnostic_context.rb:323:in `block in create_with_logging_context'
 | 
 | 


Version-Release number of selected component (if applicable):
Satellite 6.2

RHEL 5.11:
# rpm -q subscription-manager python-rhsm
subscription-manager-1.11.3-14.el5_11
python-rhsm-1.11.3-5.el5



How reproducible:
100%

Steps to Reproduce:
1. Register 5.11 system to Satellite 6.2

2. On Satellite: tailf /var/log/candlepin/candlepin.log /var/log/foreman/production.log
On 5.11: subscription-manager release {--list,--set 5Server}
3. See traceback.

Actual results:
Traceback, cannot set release or list releases from 5.11 Host. Can only set inside the Satellite WebUI.

Expected results:
Release should list or set.

Comment 2 Craig Donnelly 2016-08-02 21:04:47 UTC
Additionally, this issue is ONLY SEEN WHILE REGISTERED TO A SATELLITE.

You will not hit this issue if you are registered to the Customer Portal.

Do not close this issue.

Comment 5 Barnaby Court 2016-08-03 15:47:33 UTC
The katello API layer seems to be overriding the version & removing the release value from the response. I believe this is the source of the traceback in subscription manager:

Running a quick test locally I see the following discrepancy between the status check between the katello API and the candlepin API directly:

[root@rhel6 ~]# curl -s --cert /etc/pki/consumer/cert.pem  --key /etc/pki/consumer/key.pem  -k -X GET https://sat-rhel7.example.com/rhsm/status -H "Content-Type:application/json" | python -m json.tool
{
    "managerCapabilities": [
        "cores", 
        "ram", 
        "instance_multiplier", 
        "derived_product", 
        "cert_v3", 
        "guest_limit", 
        "vcpu", 
        "storage_band"
    ], 
    "result": true, 
    "rulesSource": "DEFAULT", 
    "rulesVersion": "5.15.2", 
    "standalone": true, 
    "timeUTC": "2016-08-03T15:23:38.454Z", 
    "version": "3.0.0.68"
}
[root@rhel6 ~]# curl -s --cert /etc/pki/consumer/cert.pem  --key /etc/pki/consumer/key.pem  -k -X GET https://sat-rhel7.example.com:8443/candlepin/status -H "Content-Type:application/json" | python -m json.tool 
{
    "managerCapabilities": [
        "cores", 
        "ram", 
        "instance_multiplier", 
        "derived_product", 
        "cert_v3", 
        "guest_limit", 
        "vcpu", 
        "storage_band"
    ], 
    "release": "1", 
    "result": true, 
    "rulesSource": "DEFAULT", 
    "rulesVersion": "5.15.2", 
    "standalone": true, 
    "timeUTC": "2016-08-03T15:24:06.137+0000", 
    "version": "0.9.54.7"
}

Comment 6 Barnaby Court 2016-08-03 21:03:46 UTC
Comment 5 is an issue but may not be related. I have been able to reproduce the problem and will continue to investigate

Comment 11 Bryan Kearney 2017-02-07 18:13:44 UTC
*** Bug 1241572 has been marked as a duplicate of this bug. ***

Comment 17 Justin Sherrill 2018-03-02 15:36:26 UTC
To clarify the issue found in https://bugzilla.redhat.com/show_bug.cgi?id=1362686#c5 doesn't actually affect this.  The problem is that sub-man does not respect any content prefix when fetching its 'cdn'.  In this case /pulp/repos.  A sub-man update is required.  Moving to the candlepin team


Note You need to log in before you can comment on or make changes to this bug.