Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 136268 - Add extras packages the BRs
Summary: Add extras packages the BRs
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gstreamer-plugins-good
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact:
URL:
Whiteboard:
: 229312 (view as bug list)
Depends On: Merge 239132
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-19 00:28 UTC by David Mohring
Modified: 2009-09-21 19:51 UTC (History)
3 users (show)

Fixed In Version: 0.10.5-6.fc7
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-18 17:33:34 UTC


Attachments (Terms of Use)
gstreamer-plugins.spec (deleted)
2004-10-19 00:29 UTC, David Mohring
no flags Details
Diff of removed sources from libshout to libshoutogg (deleted)
2004-10-19 00:32 UTC, David Mohring
no flags Details
libshoutogg tarball (deleted)
2004-10-19 00:34 UTC, David Mohring
no flags Details
patch for gst-plugins-0.8.5/ext/shout2/gstshout2.c (deleted)
2004-10-19 00:36 UTC, David Mohring
no flags Details | Diff

Description David Mohring 2004-10-19 00:28:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041016
Firefox/0.10.1

Description of problem:
While Fedora's gstreamer is crippled by the lack of some codecs, It
would be better to support and promote any relatively unencumbered
codecs or protocols as much as possible. For example: streaming
ogg/theora.

The following attachments include the modifed spec file and extra
sources to static build and link a hacked version of Icecast's
libshout2 library,  
http://www.icecast.org/download.php
with ONLY OGG support built in, for Gstreamer's shout2send sink

gst-inspect-gui 
  Sync>Network>shout2send

Or

gst-inspect shout2send



Version-Release number of selected component (if applicable):
gstreamer-plugins-0.8.5-1

How reproducible:
Sometimes

Steps to Reproduce:
See the attachments. 

Additional info:

Note that gst-inspect-gui Sync>Network>shout2send 
still shows mp3 support, I forgot to remove it from the register. Will
fix tonight.

Comment 1 David Mohring 2004-10-19 00:29:40 UTC
Created attachment 105406 [details]
gstreamer-plugins.spec

Comment 2 David Mohring 2004-10-19 00:32:48 UTC
Created attachment 105407 [details]
Diff of removed sources from libshout to libshoutogg

Comment 3 David Mohring 2004-10-19 00:34:07 UTC
Created attachment 105408 [details]
libshoutogg tarball

Comment 4 David Mohring 2004-10-19 00:36:51 UTC
Created attachment 105409 [details]
patch for gst-plugins-0.8.5/ext/shout2/gstshout2.c

Comment 5 Colin Walters 2004-10-20 20:16:33 UTC
Hi, the patches are appreciated, but this looks like something that should go
upstream, not here.  Can you file a bug on http://bugzilla.gnome.org, product
GStreamer, component gst-plugins?

Comment 6 David Mohring 2004-10-20 21:51:31 UTC
It's not an issue for the gstreamer developers. The added
functionality is to get around parts of the source code that
Redhat/FedoraCore removed due to concern of patents about MP3.

For example, with inclusion of libshout2ogg, following now works on
either the Freshrpms or FC3.

gst-launch alsasrc device=hw:1,0 ! vorbisenc bitrate=32000  !
shout2send ip=XXX.XXX.XXX.XXX port=8000 password=hackme mount=test1 
name="testing" protocol=3

It promotes the use of Vorbis OGG as a replacment for MP3.

Comment 7 Colin Walters 2004-10-21 17:48:19 UTC
I'm not sure I understand.  Isn't streaming Vorbis useful even if you have mp3
support?  The upstream GStreamer developers are the ones qualified to review and
integrate this code if they want, not me.  

Comment 8 John Thacker 2004-11-04 16:06:16 UTC
Colin-- you misunderstand somewhat.  GStreamer already supports
streaming Vorbis.  Problem is that the same plugin supports both
streaming Vorbis and streaming mp3.  As a result, FC3 just doesn't
ship the plugin at all, because of mp3 patent concerns.  This patch
leaves in the Vorbis support, but removes the mp3 support.  As such,
the GStreamer guys are not going to want to integrate it upstream,
since it only removes functionality.

It's much better than not shipping the plugin at all for people who
don't add mp3 support.  Disadvantage:  People who _do_ want streaming
mp3 support would have to replace a plugin instead of just adding a
missing one, making the packaging more irritating.

Comment 9 Kyrre Ness Sjøbæk 2004-11-04 17:53:37 UTC
Just out of curiosity: Is the transport protocoll patented? Or just
the codek?

Because: if the mp3 decoding part is missing - we won't break any
patents, right?

As far as i can see - nobody can say anything about shipping this
plugin. It is just a system for downloading mp3s and oggs, not playing
them? As far as i can see, the justification for not shipping it is
about as bad as if anybody mentioned not to ship http/ftp - as it MAY
be used to download patent-encumbered mp3's...

Comment 10 Colin Walters 2004-11-04 18:23:42 UTC
John: Thanks for the explanation, I am just dense apparently :)
I'll have a look at getting the patch into FC4.

Comment 11 Colin Walters 2004-11-09 22:25:26 UTC
Ok, I had a look at this.  We have the additional issue of course that we don't
package libshout2.  I'll have to have a look at packaging that first.


Comment 12 Rahul Sundaram 2004-11-14 09:43:41 UTC
You should probably tell upstream to split up the plugins to support
mp3 and ogg vorbis independantly

Comment 13 Matt Domsch 2005-11-25 23:46:54 UTC
Is the proper bug to request libshout be upgraded to libshout2 for FC5-devel? 
Or should that be a separate request?  ices2 will require libshout2.

Comment 14 Bastien Nocera 2007-02-01 14:40:15 UTC
Note that libshout 2.2.x is in the Extras now.

If somebody fancies getting the single plugin (2 source files!) compiled in its
own package, I don't think anyone would mind very much.

Either that, or wait until libshout is in "Fedora" (not Core/Extras) and depend
on it then.

Comment 15 Adam Jackson 2007-04-04 16:43:12 UTC
*** Bug 229312 has been marked as a duplicate of this bug. ***

Comment 16 Bastien Nocera 2007-04-04 16:49:51 UTC
We need to add those to the BRs:
libshout-devel
taglib-devel
libcdio-devel

Comment 17 Matthias Clasen 2007-04-17 16:39:30 UTC
Moving off FC7Target

Comment 18 Bastien Nocera 2007-05-18 17:33:34 UTC
Matthias fixed this. Fixed in 0.10.5-6.fc7


Note You need to log in before you can comment on or make changes to this bug.