Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1362658 - sensors-detect version and date string missing
Summary: sensors-detect version and date string missing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: lm_sensors
Version: 7.3
Hardware: All
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Martin Sehnoutka
QA Contact: Rachel Sibley
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-02 19:09 UTC by Rachel Sibley
Modified: 2016-11-04 06:39 UTC (History)
2 users (show)

Fixed In Version: lm_sensors-3.4.0-4.20160601gitf9185e5.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 06:39:08 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2450 normal SHIPPED_LIVE lm_sensors bug fix update 2016-11-03 14:03:53 UTC

Description Rachel Sibley 2016-08-02 19:09:42 UTC
Description of problem:
With the latest lm_sesors rpm, I'm seeing an usual version string of 'lm_sensors-3.4.0-2.20160601gitf9185e5.el7.x86_64',
also when you run sensors-detect the date and version are missing from the beginning output, instead you will see $REVISION$
printed.

Version-Release number of selected component (if applicable):
lm_sensors-3.4.0-2.20160601gitf9185e5.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. yum install lm_sensors
2. rpm -q lm_sensors
3. sensors-detect

Actual results:
# rpm -q lm_sensors
lm_sensors-3.4.0-2.20160601gitf9185e5.el7.x86_64
# sensors-detect
# sensors-detect revision $Revision$
....

Expected results:
rpm -q lm_sensors
lm_sensors-3.4.0-2.el7.x86_64
~]# sensors-detect
# sensors-detect revision 6170 (2013-05-20 21:25:22 +0200)
....

Additional info:

Comment 6 Rachel Sibley 2016-09-07 14:13:40 UTC
ALL TESTS PASSED

Version string is now printed correctly in the lm_sensors-3.4.0-4.20160601gitf9185e5.el7 version using sensors-detect

~]# rpm -q lm_sensors
lm_sensors-3.4.0-4.20160601gitf9185e5.el7.x86_64

~]# sensors-detect
# sensors-detect revision 3.4.0-4 (2016-06-01)
# System: Dell Inc. PowerEdge R510
# Board: Dell Inc. 0W844P
# Kernel: 3.10.0-501.el7.x86_64 x86_64
# Processor: Intel(R) Xeon(R) CPU X5550 @ 2.67GHz (6/26/5)

Comment 8 errata-xmlrpc 2016-11-04 06:39:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2450.html


Note You need to log in before you can comment on or make changes to this bug.