Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1362616 - 4K no longer possible with HDMI [NEEDINFO]
Summary: 4K no longer possible with HDMI
Keywords:
Status: CLOSED INSUFFICIENT_DATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 24
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-02 16:23 UTC by Troy A. Griffitts
Modified: 2017-04-28 17:27 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-28 17:27:05 UTC
jforbes: needinfo?


Attachments (Terms of Use)

Description Troy A. Griffitts 2016-08-02 16:23:07 UTC
Description of problem:
Before kernel upgrade, 4K monitors worked at full resolution (@30Hz) via HDMI port.  Now 4k is not possible (tried multiple monitors) via HDMI. MiniDP port still works at 4K.  Booting previous kernel still works via HDMI at 4K.

Version-Release number of selected component (if applicable):

4.6.4-301.fc24.x86_64
4.6.3-300.fc24.x86_64

How reproducible:

Boot latest kernel and plug a 4K monitor into an HDMI port, notice 1920x1080 resolution.

Boot kernel 4.5.7-300.fc24.x86_64 and plug a 4K monitor into an HDMI port, notice 3840x2160 resolution

Steps to Reproduce:
1. Boot kernel >= 4.6.3-300.fc24.x86_64
2. Connect 4K monitor via HDMI port
3. Notice 1920x1080 resolution

Actual results:
HDMI only supports 1920x1080 resolution

Expected results:
HDMI should support (previously supported) 3840x2160 @30Hz


Additional info:

Comment 1 Troy A. Griffitts 2016-08-02 16:25:36 UTC
Hardware: Dell Precision M3800

Comment 2 Troy A. Griffitts 2016-09-17 20:28:50 UTC
This is getting worse.  With the latest kernel, I can now no longer get 4K on this laptop with the mini-displayport.

Linux charisLaptop 4.7.3-200.fc24.x86_64 #1 SMP Wed Sep 7 17:31:21 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

Comment 3 Justin M. Forbes 2017-04-11 14:50:06 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There are a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 24 kernel bugs.

Fedora 25 has now been rebased to 4.10.9-100.fc24.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 26, and are still experiencing this issue, please change the version to Fedora 26.

If you experience different issues, please open a new bug report for those.

Comment 4 Justin M. Forbes 2017-04-28 17:27:05 UTC
*********** MASS BUG UPDATE **************
This bug is being closed with INSUFFICIENT_DATA as there has not been a response in 2 weeks. If you are still experiencing this issue, please reopen and attach the 
relevant data from the latest kernel you are running and any data that might have been requested previously.


Note You need to log in before you can comment on or make changes to this bug.