Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1362604 - Inlcude rng-tools package
Summary: Inlcude rng-tools package
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-node
Classification: oVirt
Component: Installation & Update
Version: 4.1
Hardware: x86_64
OS: Linux
medium
high vote
Target Milestone: ovirt-4.1.0-rc
: 4.1
Assignee: Douglas Schilling Landgraf
QA Contact: jianwu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-02 15:34 UTC by Nikolai Sednev
Modified: 2018-06-14 03:24 UTC (History)
9 users (show)

Fixed In Version: ovirt-release-host-node-4.1.0-0.7
Doc Type: Enhancement
Doc Text:
The rng-tools package has been added to oVirt Node NG / RHV-H. This tool is required for the TPM module to be able to work with the Random Number Generator.
Clone Of:
Environment:
Last Closed: 2017-02-15 14:58:12 UTC
oVirt Team: Node
rule-engine: ovirt-4.1+
rule-engine: blocker+
rule-engine: planning_ack+
fdeutsch: devel_ack+
ycui: testing_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 62965 master MERGED node: Add requirement to rng-tools 2016-08-30 05:49:26 UTC

Description Nikolai Sednev 2016-08-02 15:34:45 UTC
Description of problem:
rng-tools not included in NGN RHVH-7.2-20160801.10-RHVH-x86_64-dvd1.iso
Without these tools it'll be impossible to have TPM module working with Random Number Generator in RHEVM.

Version-Release number of selected component (if applicable):
RHVH-7.2-20160801.10-RHVH-x86_64-dvd1.iso

How reproducible:
100%

Steps to Reproduce:
1.Deploy RHVH-7.2-20160801.10-RHVH-x86_64-dvd1.iso on host.
2.Check if rpm -qa rng-tools exists.
3.Check systemctl status rngd 

Actual results:
On NGN this rpm is missing and making Random Number Generator functionality impossible.

Expected results:
Package should exist on NGN just like it exists on regular RHEL7.2 and rngd should be running.

Additional info:

Comment 1 Fabian Deutsch 2016-08-03 10:53:39 UTC
Shouldn't vdsm be pulling in rng-tools?

Comment 2 Nikolai Sednev 2016-08-03 12:29:16 UTC
I also see that its missing in latest  RHVH-7.2-20160801.10-RHVH-x86_64-dvd1.iso. I've added the host to the engine after it was cleanly installed from that ISO image.  

ovirt-setup-lib-1.0.2-1.el7ev.noarch
sanlock-3.2.4-2.el7_2.x86_64
ovirt-vmconsole-host-1.0.4-1.el7ev.noarch
ovirt-hosted-engine-setup-2.0.1.3-1.el7ev.noarch
ovirt-vmconsole-1.0.4-1.el7ev.noarch
ovirt-host-deploy-1.5.1-1.el7ev.noarch
ovirt-engine-sdk-python-3.6.7.0-1.el7ev.noarch
qemu-kvm-rhev-2.3.0-31.el7_2.16.x86_64
libvirt-client-1.2.17-13.el7_2.5.x86_64
vdsm-4.18.9-1.el7ev.x86_64
ovirt-hosted-engine-ha-2.0.1-1.el7ev.noarch
ovirt-imageio-daemon-0.3.0-0.el7ev.noarch
mom-0.5.5-1.el7ev.noarch
ovirt-imageio-common-0.3.0-0.el7ev.noarch
Linux version 3.10.0-327.22.2.el7.x86_64 (mockbuild@x86-030.build.eng.bos.redhat.com) (gcc version 4.8.5 20150623 (Red Hat 4.8.5-4) (GCC) ) #1 SMP Thu Jun 9 10:09:10 EDT 2016
Linux 3.10.0-327.22.2.el7.x86_64 #1 SMP Thu Jun 9 10:09:10 EDT 2016 x86_64 x86_64 x86_64 GNU/Linux
Red Hat Enterprise Linux release 7.2

Comment 3 Martin Polednik 2016-08-04 07:45:56 UTC
TPM hwrng is just one example of hardware rng. There will still be
 a) typical PRNG (/dev/random, seealso #1347642),
 b) any other hwrng (such as proper plug-in RNG generator).

Having rng-tools by default could still be small quality of life improvement.

For VDSM it doesn't make sense to require it.

Comment 4 Nikolai Sednev 2016-08-07 08:57:32 UTC
/dev/hwrng is the default option and if used, in many cases it will be used as /dev/hwrng, mostly because of its HW based, thus much faster from performance side. 

The lack of this component makes impossible usage of "Random Number Generator functionality", which will actually turn all VMs that uses it, to VMs that will be unable to even get started. 

Please consider adding a blocker to this bug.

Comment 5 Red Hat Bugzilla Rules Engine 2016-08-07 10:46:24 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 6 jianwu 2017-01-17 06:16:53 UTC
Hi, all

I have reproduce this bug on redhat-virtualization-host-4.1-20170116.0 as follows:


Steps to Reproduce:
1.Successfully install RHVH new build on my local machine .
2.Check if rpm -qa rng-tools exists.
3.Check systemctl status rngd 

Actual results:
#rpm -qa|grep rng-tools
no message output
#systemctl status rngd 
Unit rngd.service could not be found.

On NGN this rpm is missing and making Random Number Generator functionality impossible.

So I think this bug is not fixed now, I will change status to ASSIGN.

Jianwu

Thanks

Comment 8 Ryan Barry 2017-01-17 14:54:54 UTC
This is already part of ovirt-release-host-node upstream in 4.1

Comment 11 cshao 2017-02-06 07:07:12 UTC
Test version:
redhat-virtualization-host-4.1-20170202.0
ovirt-node-ng-installer-ovirt-4.1-2017020112.iso

Test result:
The rng-tools package has been added to oVirt Node NG / RHV-H.

# imgbase w
[INFO] You are on rhvh-4.1-0.20170202.0+1
# rpm -qa|grep rng-tools
rng-tools-5-8.el7.x86_64
# 

# imgbase w
[INFO] You are on ovirt-node-ng-4.1.0-0.20170201.0+1
# rpm -qa| grep rng-tools
rng-tools-5-8.el7.x86_64
#

So the bug is fixed, change bug status to VERIFIED.


Note You need to log in before you can comment on or make changes to this bug.