Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1362602 - [Open SSL] : Unable to mount an SSL enabled volume via SMB v3/Ganesha v4
Summary: [Open SSL] : Unable to mount an SSL enabled volume via SMB v3/Ganesha v4
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: libgfapi
Version: mainline
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: rjoseph
QA Contact: Sudhir D
URL:
Whiteboard:
Depends On: 1340608 1371475
Blocks: Gluster-HC-2 1311843 1371650
TreeView+ depends on / blocked
 
Reported: 2016-08-02 15:29 UTC by rjoseph
Modified: 2017-03-27 18:25 UTC (History)
9 users (show)

Fixed In Version: glusterfs-3.9.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1340608
: 1371650 (view as bug list)
Environment:
Last Closed: 2017-03-27 18:25:08 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Vijay Bellur 2016-08-02 15:49:47 UTC
REVIEW: http://review.gluster.org/15072 (socket: SSL_shutdown should not be called after socket disconnet) posted (#1) for review on master by Rajesh Joseph (rjoseph@redhat.com)

Comment 2 Vijay Bellur 2016-08-02 15:49:52 UTC
REVIEW: http://review.gluster.org/15073 (gfapi: SSL connection for mgmt connection is not working) posted (#1) for review on master by Rajesh Joseph (rjoseph@redhat.com)

Comment 3 Vijay Bellur 2016-08-04 05:57:03 UTC
REVIEW: http://review.gluster.org/15072 (socket: SSL_shutdown should not be called after socket disconnet) posted (#2) for review on master by Rajesh Joseph (rjoseph@redhat.com)

Comment 4 Vijay Bellur 2016-08-04 05:57:07 UTC
REVIEW: http://review.gluster.org/15073 (gfapi: SSL connection for mgmt connection is not working) posted (#2) for review on master by Rajesh Joseph (rjoseph@redhat.com)

Comment 5 Vijay Bellur 2016-08-04 08:39:19 UTC
REVIEW: http://review.gluster.org/15072 (socket: SSL_shutdown should not be called after socket disconnet) posted (#3) for review on master by Rajesh Joseph (rjoseph@redhat.com)

Comment 6 Vijay Bellur 2016-08-04 08:39:23 UTC
REVIEW: http://review.gluster.org/15073 (gfapi: SSL connection for mgmt connection is not working) posted (#3) for review on master by Rajesh Joseph (rjoseph@redhat.com)

Comment 7 Vijay Bellur 2016-08-04 15:47:14 UTC
REVIEW: http://review.gluster.org/15072 (socket: SSL_shutdown should not be called after socket disconnect) posted (#4) for review on master by Rajesh Joseph (rjoseph@redhat.com)

Comment 8 Vijay Bellur 2016-08-05 05:49:30 UTC
REVIEW: http://review.gluster.org/15072 (socket: SSL_shutdown should not be called after socket disconnet) posted (#5) for review on master by Rajesh Joseph (rjoseph@redhat.com)

Comment 9 Vijay Bellur 2016-08-05 05:49:34 UTC
REVIEW: http://review.gluster.org/15073 (gfapi: SSL connection for mgmt connection is not working) posted (#4) for review on master by Rajesh Joseph (rjoseph@redhat.com)

Comment 10 Vijay Bellur 2016-08-05 12:31:07 UTC
REVIEW: http://review.gluster.org/15072 (socket: SSL_shutdown should not be called after socket disconnet) posted (#6) for review on master by Rajesh Joseph (rjoseph@redhat.com)

Comment 11 Vijay Bellur 2016-08-05 12:31:12 UTC
REVIEW: http://review.gluster.org/15073 (gfapi: SSL connection for mgmt connection is not working) posted (#5) for review on master by Rajesh Joseph (rjoseph@redhat.com)

Comment 12 Vijay Bellur 2016-08-11 15:11:14 UTC
REVIEW: http://review.gluster.org/15072 (socket: SSL_shutdown should be called before socket shutdown) posted (#7) for review on master by Rajesh Joseph (rjoseph@redhat.com)

Comment 13 Vijay Bellur 2016-08-11 15:11:20 UTC
REVIEW: http://review.gluster.org/15073 (gfapi: SSL connection for mgmt connection is not working) posted (#6) for review on master by Rajesh Joseph (rjoseph@redhat.com)

Comment 14 Vijay Bellur 2016-08-16 19:46:48 UTC
COMMIT: http://review.gluster.org/15072 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit 79e006b31a1e6d71f1af02176f8e8acaed7f8cd2
Author: Rajesh Joseph <rjoseph@redhat.com>
Date:   Tue Aug 2 15:30:27 2016 +0000

    socket: SSL_shutdown should be called before socket shutdown
    
    SSL_shutdown shuts down an active SSL connection. But we
    are calling this after underlying socket is disconnected.
    
    Change-Id: Ia943179d23395f42b942450dbcf26336d4dfc813
    BUG: 1362602
    Signed-off-by: Rajesh Joseph <rjoseph@redhat.com>
    Reviewed-on: http://review.gluster.org/15072
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>

Comment 15 Vijay Bellur 2016-08-17 06:23:57 UTC
REVIEW: http://review.gluster.org/15073 (gfapi: SSL connection for mgmt connection is not working) posted (#7) for review on master by Rajesh Joseph (rjoseph@redhat.com)

Comment 16 Vijay Bellur 2016-08-19 11:55:40 UTC
REVIEW: http://review.gluster.org/15073 (gfapi: SSL connection for mgmt connection is not working) posted (#8) for review on master by Rajesh Joseph (rjoseph@redhat.com)

Comment 17 Worker Ant 2016-08-24 05:59:30 UTC
REVIEW: http://review.gluster.org/15073 (gfapi: SSL connection for mgmt connection is not working) posted (#9) for review on master by Rajesh Joseph (rjoseph@redhat.com)

Comment 18 Worker Ant 2016-08-24 10:13:48 UTC
REVIEW: http://review.gluster.org/15073 (gfapi: SSL connection for mgmt connection is not working) posted (#10) for review on master by Rajesh Joseph (rjoseph@redhat.com)

Comment 19 Worker Ant 2016-08-29 06:19:37 UTC
COMMIT: http://review.gluster.org/15073 committed in master by Kaushal M (kaushal@redhat.com) 
------
commit 62f4e41e9eafd2838d2a11989f08b0e7627284b4
Author: Rajesh Joseph <rjoseph@redhat.com>
Date:   Tue Aug 2 15:33:34 2016 +0000

    gfapi: SSL connection for mgmt connection is not working
    
    Problem: libgfapi does not enable SSL on mgmt connection.
    
    Fix: Enable SSL when it is enabled on mgmt connection is enabled,
    i.e. presence of /var/lib/glusterd/secure-access file
    
    Change-Id: I1ce4935b04e6140aeab819e42076defd580b0727
    BUG: 1362602
    Signed-off-by: Rajesh Joseph <rjoseph@redhat.com>
    Reviewed-on: http://review.gluster.org/15073
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-by: Kaushal M <kaushal@redhat.com>

Comment 20 Shyamsundar 2017-03-27 18:25:08 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.9.0, please open a new bug report.

glusterfs-3.9.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2016-November/029281.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.