Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1362592 - After upgrade, all of my hosts are duplicated one with shortname, one with fqdn
Summary: After upgrade, all of my hosts are duplicated one with shortname, one with fqdn
Keywords:
Status: CLOSED DUPLICATE of bug 1356714
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Upgrades
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
high
high vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-02 15:07 UTC by Justin Sherrill
Modified: 2017-04-25 16:37 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-04 12:40:47 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2482641 None None None 2016-08-09 14:00:47 UTC

Description Justin Sherrill 2016-08-02 15:07:22 UTC
Description of problem:

After upgrading to satellite 6.2, all content hosts may be duplicated one with the shortname and one with the long name:

foo
foo.example.com


The reason for this is that the hosts have their hostnames configured such that the hostname command reports the shortname, while the 'hostname -f' command reports the fqdn.  The problem does not occur if 'hostname' reports the fqdn.


Version-Release number of selected component (if applicable):
6.2.1

How reproducible:
Always

Steps to Reproduce:
1.  Install 6.1
2.  Register a host with sub-man and puppet, such that the host reports its shortname via the 'hostname' command
3.  Upgrade to 6.2

Actual results:
Duplicated hosts

Expected results:
Only one host

Additional info:


'subscription-manager facts' seems to not report the fqdn at all if the host is configured this way.

Comment 2 Justin Sherrill 2016-08-04 12:40:47 UTC

*** This bug has been marked as a duplicate of bug 1356714 ***

Comment 3 Justin Sherrill 2016-08-16 20:46:48 UTC
Created redmine issue http://projects.theforeman.org/issues/16134 from this bug


Note You need to log in before you can comment on or make changes to this bug.