Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1362522 - [abrt] hplip-gui: qt_message_fatal(): python3.5 killed by SIGABRT
Summary: [abrt] hplip-gui: qt_message_fatal(): python3.5 killed by SIGABRT
Keywords:
Status: CLOSED DUPLICATE of bug 1364717
Alias: None
Product: Fedora
Classification: Fedora
Component: qt5-qtbase
Version: 24
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:c63d070a49d9b9920206e3c087a...
: 1397903 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-02 12:27 UTC by bharatt hareindharan
Modified: 2017-07-18 12:03 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-07-18 12:03:46 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2016-08-02 12:28 UTC, bharatt hareindharan
no flags Details
File: cgroup (deleted)
2016-08-02 12:28 UTC, bharatt hareindharan
no flags Details
File: core_backtrace (deleted)
2016-08-02 12:28 UTC, bharatt hareindharan
no flags Details
File: dso_list (deleted)
2016-08-02 12:28 UTC, bharatt hareindharan
no flags Details
File: environ (deleted)
2016-08-02 12:28 UTC, bharatt hareindharan
no flags Details
File: limits (deleted)
2016-08-02 12:28 UTC, bharatt hareindharan
no flags Details
File: maps (deleted)
2016-08-02 12:28 UTC, bharatt hareindharan
no flags Details
File: mountinfo (deleted)
2016-08-02 12:28 UTC, bharatt hareindharan
no flags Details
File: namespaces (deleted)
2016-08-02 12:28 UTC, bharatt hareindharan
no flags Details
File: open_fds (deleted)
2016-08-02 12:28 UTC, bharatt hareindharan
no flags Details
File: proc_pid_status (deleted)
2016-08-02 12:28 UTC, bharatt hareindharan
no flags Details
File: var_log_messages (deleted)
2016-08-02 12:28 UTC, bharatt hareindharan
no flags Details

Description bharatt hareindharan 2016-08-02 12:27:59 UTC
Version-Release number of selected component:
hplip-gui-3.16.7-1.fc24

Additional info:
reporter:       libreport-2.7.1
backtrace_rating: 4
cmdline:        /usr/bin/python3 /usr/bin/hp-toolbox
crash_function: qt_message_fatal
executable:     /usr/bin/python3.5
global_pid:     11987
kernel:         4.6.3-300.fc24.x86_64
pkg_fingerprint: 73BD E983 81B4 6521
pkg_vendor:     Fedora Project
reproducible:   Not sure how to reproduce the problem
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 qt_message_fatal at global/qlogging.cpp:1610
 #3 QMessageLogger::fatal at global/qlogging.cpp:784
 #4 pyqt5_err_print at ../../qpy/QtCore/qpycore_public_api.cpp:191
 #5 PyQtSlotProxy::unislot at ../../qpy/QtCore/qpycore_pyqtslotproxy.cpp:211
 #6 PyQtSlotProxy::qt_metacall at ../../qpy/QtCore/qpycore_pyqtslotproxy.cpp:170
 #7 QMetaObject::activate at kernel/qobject.cpp:3745
 #9 QAbstractButton::clicked at .moc/moc_qabstractbutton.cpp:307
 #10 QAbstractButtonPrivate::emitClicked at widgets/qabstractbutton.cpp:533
 #11 QAbstractButtonPrivate::click at widgets/qabstractbutton.cpp:526
 #12 QAbstractButton::mouseReleaseEvent at widgets/qabstractbutton.cpp:1131

Comment 1 bharatt hareindharan 2016-08-02 12:28:08 UTC
Created attachment 1186782 [details]
File: backtrace

Comment 2 bharatt hareindharan 2016-08-02 12:28:09 UTC
Created attachment 1186783 [details]
File: cgroup

Comment 3 bharatt hareindharan 2016-08-02 12:28:11 UTC
Created attachment 1186784 [details]
File: core_backtrace

Comment 4 bharatt hareindharan 2016-08-02 12:28:13 UTC
Created attachment 1186785 [details]
File: dso_list

Comment 5 bharatt hareindharan 2016-08-02 12:28:15 UTC
Created attachment 1186786 [details]
File: environ

Comment 6 bharatt hareindharan 2016-08-02 12:28:18 UTC
Created attachment 1186787 [details]
File: limits

Comment 7 bharatt hareindharan 2016-08-02 12:28:25 UTC
Created attachment 1186788 [details]
File: maps

Comment 8 bharatt hareindharan 2016-08-02 12:28:30 UTC
Created attachment 1186789 [details]
File: mountinfo

Comment 9 bharatt hareindharan 2016-08-02 12:28:33 UTC
Created attachment 1186790 [details]
File: namespaces

Comment 10 bharatt hareindharan 2016-08-02 12:28:35 UTC
Created attachment 1186791 [details]
File: open_fds

Comment 11 bharatt hareindharan 2016-08-02 12:28:36 UTC
Created attachment 1186792 [details]
File: proc_pid_status

Comment 12 bharatt hareindharan 2016-08-02 12:28:39 UTC
Created attachment 1186793 [details]
File: var_log_messages

Comment 13 jibecfed 2016-08-29 19:53:01 UTC
Similar problem has been detected:

it detected printer, then crashed

reporter:       libreport-2.7.2
backtrace_rating: 4
cmdline:        /usr/bin/python3 /usr/bin/hp-setup
crash_function: qt_message_fatal
executable:     /usr/bin/python3.5
global_pid:     5936
kernel:         4.6.7-300.fc24.x86_64
package:        hplip-3.16.7-2.fc24
pkg_fingerprint: 73BD E983 81B4 6521
pkg_vendor:     Fedora Project
reason:         python3.5 killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 14 Zdenek Dohnal 2016-11-23 08:15:39 UTC
Abort happened in qt5, reassigning to qt5-qtbase.

Comment 15 Zdenek Dohnal 2016-11-23 08:19:01 UTC
Seems like duplicate of #1257267.

Comment 16 Zdenek Dohnal 2016-11-24 08:28:58 UTC
*** Bug 1397903 has been marked as a duplicate of this bug. ***

Comment 17 Ngo Than 2017-07-18 12:03:46 UTC

*** This bug has been marked as a duplicate of bug 1364717 ***


Note You need to log in before you can comment on or make changes to this bug.