Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1362520 - Per xlator logging not working
Summary: Per xlator logging not working
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: logging
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Poornima G
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-02 12:24 UTC by Poornima G
Modified: 2017-03-27 18:19 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.9.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-27 18:19:04 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Poornima G 2016-08-02 12:24:29 UTC
Description of problem:

logging: Fix per xl log level.

Currently per xlator loglevel setting doesn't work, due to the flaw in loglevel checking. Fix the same. Per xlator logging can be set using the below command: Eg: setfattr -n trusted.glusterfs.patchy-md-cache.set-log-level -v TRACE /mnt/glusterfs/0 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Vijay Bellur 2016-08-02 12:40:48 UTC
REVIEW: http://review.gluster.org/15071 (logging: Fix per xl log level) posted (#2) for review on master by Poornima G (pgurusid@redhat.com)

Comment 2 Vijay Bellur 2016-08-04 11:09:47 UTC
REVIEW: http://review.gluster.org/15071 (logging: Fix per xl log level) posted (#3) for review on master by Poornima G (pgurusid@redhat.com)

Comment 3 Vijay Bellur 2016-08-11 07:29:17 UTC
REVIEW: http://review.gluster.org/15071 (logging: Fix per xl log level) posted (#4) for review on master by Poornima G (pgurusid@redhat.com)

Comment 4 Vijay Bellur 2016-08-15 12:04:18 UTC
COMMIT: http://review.gluster.org/15071 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit 206fd324e33127d4c370007f223f8c12ab06b714
Author: Poornima G <pgurusid@redhat.com>
Date:   Tue Aug 2 16:17:36 2016 +0530

    logging: Fix per xl log level
    
    Currently per xlator loglevel setting doesn't work, due to the
    flaw in loglevel checking. Fix the same.
    
    Per xlator logging can be set using the below command:
    
    Eg: setfattr -n trusted.glusterfs.patchy-md-cache.set-log-level -v TRACE /mnt/glusterfs/0
    
    Change-Id: I8ff1d15bd5693b6f682d99bee22a4bbb5eee646c
    BUG: 1362520
    Signed-off-by: Poornima G <pgurusid@redhat.com>
    Reviewed-on: http://review.gluster.org/15071
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>

Comment 5 Shyamsundar 2017-03-27 18:19:04 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.9.0, please open a new bug report.

glusterfs-3.9.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2016-November/029281.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.