Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1362480 - Same configuration of lldptool work in RHEL7 and not in RHEL6
Summary: Same configuration of lldptool work in RHEL7 and not in RHEL6
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lldpad
Version: 6.5
Hardware: All
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Chris Leech
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-02 10:43 UTC by Davide F Bragalone
Modified: 2017-06-05 19:00 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-05 19:00:09 UTC


Attachments (Terms of Use)

Description Davide F Bragalone 2016-08-02 10:43:40 UTC
Description of problem:

Customer wants to enable lldpad for each eth interface - but only in rx mode - even if they are bonded, submitting the following command for each slave interface:
   #lldptool set-lldp -i *interface* adminStatus=rx

He noticed that the same configuration in RHEL 6.5 does NOT consistently give this information even though it has received numerous packets.
If run on a for loop, the information is only displayed occasionally, see the example below.

root@ll-lab-seng-01 # lldptool -S -i eth2 adminStatus
Total Frames Transmitted        = 0
Total Discarded Frames Received = 0
Total Error Frames Received     = 0
Total Frames Received           = 2066
Total Discarded TLVs            = 0
Total Unrecognized TLVs         = 0
Total Ageouts                   = 0

root@ll-lab-seng-01 # while true; do lldptool get-tlv -n -i eth2; echo "----"; sleep 1; done
----
----
----
----
----
----
----
----
----
----
----
----
----
----
----
----
----
Chassis ID TLV
        MAC: 3c:94:d5:0c:cb:f0
Port ID TLV
        Local: 1117
Time to Live TLV
        120
System Name TLV
        ll-lt-int-core-02
System Description TLV
        Juniper Networks, Inc. ex8208 , version 12.3R7.7 Build date: 2014-06-12 16:00:35 UTC 
System Capabilities TLV
        System capabilities:  Bridge, Router
        Enabled capabilities: Bridge, Router
Management Address TLV
        IPv4: 10.8.102.253
        Unknown interface subtype: 0
        OID: 
Port Description TLV
        ll-lab-osis-01_nicb
MAC/PHY Configuration Status TLV
        Auto-negotiation supported and enabled
        PMD auto-negotiation capabilities: 0x6c11
        MAU type: Unknown [0x0000]
Link Aggregation TLV
        Aggregation capable
        Currently not aggregated
        Aggregated Port ID: 0
Maximum Frame Size TLV
        1514
Port VLAN ID TLV
        PVID: 3200
VLAN Name TLV
        VID 3200: Name v3200-Exchange
LLDP-MED Capabilities TLV
        Device Type:  netcon
        Capabilities: LLDP-MED, Network Policy, Location Identification, Extended Power via MDI-PSE
End of LLDPDU TLV
----
----
c^C

It's almost like its not caching the information, even though it should be.
Please note this has the exact same configuration as the RHEL 7.1 box which works appropriately.

If can be useful, he is using different version of lldap for each system:
   RHEL 7.1: lldpad-0.9.46-10.el7.x86_64 
   RHEL 6.5: lldpad-0.9.46-3.el6_5.x86_64


Version-Release number of selected component (if applicable):
lldpad-0.9.46-3.el6_5.x86_64

How reproducible:
RHEL 6.5 system

Steps to Reproduce:
1.Configure bond interface with two eth slaves

2.Configure lldpad to receive only information for both eth interfaces (not the bond)
 #lldptool set-lldp -i *interface* adminStatus=rx

3.Try to get lldp info from the interface:
 #lldptool get-tlv -n -i eth*

Actual results: 
see the "for loop" example in description

Expected results:
You should get *always* ( right now is *sometimes*) information from the command:
 #lldptool get-tlv -n -i eth*


Additional info: 

1. RHEL 7.1: lldpad-0.9.46-10.el7.x86_64 
   RHEL 6.5: lldpad-0.9.46-3.el6_5.x86_64

2. The lldptool version is the same on both 6.5 and 7.1
root@ll-tc-uxfxmr-01 # lldptool -v
lldptool v0.9.46
Copyright (c) 2007-2010, Intel Corporation

Comment 2 Chris Leech 2016-09-01 20:17:11 UTC
So 0.9.46-3.el6 and 0.9.46-10.el7 actually have quite a few differences from upstream because there was a big gap in tagged releases.  We haven't updated lldpad in el6 for a while.

I might be able to figure out what exactly is impacting this, but it might be better to just build an el6 update that matches the more recent el7 code we're supporting if that's known to be working.

Comment 4 Rastislav Hepner 2016-10-10 13:28:15 UTC
Hello Chris, 

this is Rastislav I'm another support engineer working on case attached to this bug. 

I'd like to ask, do you have bw for making that testing build? Customer was asked about it some time ago and he agreed to do testing. Now he's expecting it.

Thanks

Comment 6 Chris Leech 2016-10-21 17:23:04 UTC
An el6 test build of the same source version as we shipped with 7.1 is available here

http://people.redhat.com/~cleech/bz1362480/

Comment 10 Chris Williams 2017-06-05 19:00:09 UTC
Red Hat Enterprise Linux 6 transitioned to the Production 3 Phase on May 10, 2017.  During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not appear to meet the inclusion criteria for the Production Phase 3 and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification.  Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com


Note You need to log in before you can comment on or make changes to this bug.