Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1362460 - A crash occurs when connecting to a spice guest by ssh from fedora24 to rhel7
Summary: A crash occurs when connecting to a spice guest by ssh from fedora24 to rhel7
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: spice-gtk
Version: 7.3
Hardware: x86_64
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Pavel Grunt
QA Contact: SPICE QE bug list
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-02 09:04 UTC by Xiaodai Wang
Modified: 2016-11-04 01:23 UTC (History)
7 users (show)

Fixed In Version: spice-gtk-0.31-5.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 01:23:28 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2229 normal SHIPPED_LIVE virt-viewer, libgovirt, spice-gtk, and usbredir bug fix and enhancement update 2016-11-03 13:26:58 UTC

Description Xiaodai Wang 2016-08-02 09:04:09 UTC
Description of problem:
A crash occurs when connecting to a spice guest by ssh from fedora24 to rhel7

Version-Release number of selected component (if applicable):
spice-gtk-0.31-4.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Prepare a spice guest running on rhel7 host.
2. Prepare a fedora24 host.
3. SSH to rhel7 host from fedora24.
4. Launch virt-viewer/remote-viewer to connect to a spice guest.

Actual results:
# remote-viewer spice://127.0.0.1:5900

** (remote-viewer:10597): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-7jLRj4kWh2: Connection refused

(remote-viewer:10597): GSpice-WARNING **: PulseAudio context failed Connection refused

(remote-viewer:10597): GSpice-WARNING **: pa_context_connect() failed: Connection refused

(remote-viewer:10597): GSpice-WARNING **: PulseAudio context failed Connection refused

(remote-viewer:10597): GSpice-WARNING **: pa_context_connect() failed: Connection refused

(remote-viewer:10597): GSpice-WARNING **: PulseAudio context failed Connection refused

(remote-viewer:10597): GSpice-WARNING **: pa_context_connect() failed: Connection refused
libEGL warning: DRI3: failed to query the version
libEGL warning: DRI2: failed to authenticate

(remote-viewer:10597): GSpice-CRITICAL **: egl init failed: cannot create EGL context

(remote-viewer:10597): Gdk-ERROR **: The program 'remote-viewer' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadRequest (invalid request code or no such operation)'.
  (Details: serial 325 error_code 1 request_code 153 (unknown) minor_code 1)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the GDK_SYNCHRONIZE environment
   variable to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
Trace/breakpoint trap (core dumped)


Expected results:
No crash should occur and connect to spice guest successfully.

Additional info:

Comment 1 Pavel Grunt 2016-08-02 10:07:52 UTC
It is regression since rebase - bug 1329973

Fixed upstream: https://cgit.freedesktop.org/spice/spice-gtk/commit/?id=a395ac59447dedfb922f997c7c9cff93edd53600

Comment 7 errata-xmlrpc 2016-11-04 01:23:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2229.html


Note You need to log in before you can comment on or make changes to this bug.