Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1362412 - dashboard: don't show starting-up VMs as warning
Summary: dashboard: don't show starting-up VMs as warning
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: General
Version: 4.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: ovirt-4.1.0-beta
: 4.1.0.2
Assignee: Scott Dickerson
QA Contact: Pavel Novotny
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-02 07:21 UTC by Barak Korren
Modified: 2017-03-16 14:50 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-16 14:50:00 UTC
oVirt Team: UX
rule-engine: ovirt-4.1+
rule-engine: planning_ack+
oourfali: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 70593 master MERGED engine: adjust dashboard inventory query VM status mappings 2017-01-17 07:23:58 UTC
oVirt gerrit 70605 ovirt-engine-4.1 MERGED engine: adjust dashboard inventory query VM status mappings 2017-01-17 09:20:29 UTC

Description Barak Korren 2016-08-02 07:21:07 UTC
Description of problem:
The "Virtual Machines" counter on the top of the dashboard shows a yellow "warning" triangle when it detects VMs that are in the process of starting up or shutting down.
This as probably not something an admin looking at the dashboard should be warned about.

Version-Release number of selected component (if applicable):
1.0.0-20160705git3e1e99

How reproducible:
Might be difficult to time things right

Steps to Reproduce:
1. Have a system where VMs constantly go up and down
2. Look at the dashborad, it will eventually detect VMs that are not 'up'
   or 'down' and will show then as warning.

Comment 1 Vojtech Szocs 2016-08-02 17:38:15 UTC
For VM objects, the current mapping is following [1]:

UP = [Up, SavingState, RestoringState]

WARNING = [PoweringUp, Paused, MigratingFrom, MigratingTo, Unknown, WaitForLaunch, Suspended, PoweringDown]

DOWN = [Down, NotResponding, RebootInProgress, ImageIllegal, ImageLocked]

[1] org.ovirt.engine.ui.frontend.server.dashboard.maps.VmStatusMap

So if `PoweringUp` or `PoweringDown` shouldn't be in WARNING category, where else should it be?

Comment 2 Oved Ourfali 2016-08-02 18:13:56 UTC
Well, powering up might fit up better than warning, and powering down to down. 

Although I don't have a strong opinion on that one. 

Moran?

Comment 3 Barak Korren 2016-08-03 06:44:34 UTC
IMO warning should be reserved for stuff we expect the admin to take action to resolve - so VMs should probably show up there for the following statuses:
- Paused - but perhaps only if it was paused for storage failure and not because of the user requesting to start in paused mode
- Unknown
- Down - if went down because of some system failure
- NotResponding
- ImageIllegal - not sure how you get this one, but sounds bad enough to alert the admin

Comment 4 Vojtech Szocs 2016-08-05 16:00:03 UTC
In general, Dashboard UI just reflects the status categories computed on Engine. Currently, VM inventory card shows 3 status categories: up, down, warning.

It's not a tech problem to add more status categories or reorganize existing ones. We'd need a specification for this kind of change, though.

Comment 5 Barak Korren 2016-08-07 07:42:28 UTC
I don't think more status categories are needed.
From my personal experience (which is gained from maintaining a couple of moderately large RHEV instances, but not with actual customer data, which I'd love to see PMs contribute), "up", "down" and "warning" is sufficient.

Maybe I was not clear in Comment #3. The list I specified there was the list of statuses in engine that I think should be mapped to "warning". I talked briefly with the virt team before posting, the statuses I listed should not be hard to gather from data given by the engine.

Comment 6 Oved Ourfali 2016-08-07 07:50:56 UTC
Let's wait for PM feedback.

Comment 7 Moran Goldboim 2016-08-08 19:05:50 UTC
Generally speaking, i would reffer the suggestion in Comment #3 as error state and not warning. I think there is a lot of logic in this suggestion. but AFAIR the decision around states translation to the card statuses was done based on the statuses available on the DWH, and the mapping of those to VM states?

Comment 8 Oved Ourfali 2016-11-21 15:29:05 UTC
I think PoweringUp and PoweringDown should be mapped to Up.

Comment 9 Scott Dickerson 2017-01-16 20:27:24 UTC
Based on Comment #3 and Comment #8, moving PoweringUp and PoweringDown to *Up* and ImageIllegal to *Warning*.  The full maps is:

  Up = PoweringUp, Up, SavingState, RestoringState, PoweringDown

  Warning = Paused, MigratingFrom, MigratingTo, Unknown, WaitForLaunch, Suspended, ImageIllegal

  Down = Down, NotResponding, RebootInProgress, ImageLocked

Comment 10 Pavel Novotny 2017-02-24 15:28:00 UTC
Verified in 
rhevm-4.1.1.2-0.1.el7.noarch
ovirt-engine-dashboard-1.1.0-5.el7ev.x86_64

Powering up/down VM is now reported in Dashboard inventory card as Up.

I can also confirm the Dashboard <-> VM status map mentioned in comment 9 by Scott.
Dashboard status -> VM search query:
Up -> Vm: status = poweringup or status = up or status = savingstate or status = restoringstate or status = poweringdown

Warning -> Vm: status = paused or status = migratingfrom or status = migratingto or status = unknown or status = waitforlaunch or status = suspended or status = imageillegal

Down -> Vm: status = down or status = notresponding or status = rebootinprogress or status = imagelocked


Note You need to log in before you can comment on or make changes to this bug.