Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1362397 - Mem leak in meta_default_readv in meta xlators
Summary: Mem leak in meta_default_readv in meta xlators
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: unclassified
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1364522 1365734
TreeView+ depends on / blocked
 
Reported: 2016-08-02 06:48 UTC by Mohammed Rafi KC
Modified: 2017-03-27 18:18 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.9.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1364522 (view as bug list)
Environment:
Last Closed: 2017-03-27 18:18:24 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Mohammed Rafi KC 2016-08-02 06:48:07 UTC
Description of problem:

Meta xlators leaking iobuf and iobref in read code path, from the function meta_default_readv


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. create a volume and do a fuse mount
2. read the file /mnt/.meta/version in loop
3.

Actual results:

memleak

Expected results:

there should not be any memleak

Additional info:

Comment 1 Mohammed Rafi KC 2016-08-02 06:50:25 UTC
I opened the bug in glusterd, because I couldn't find a component named meta.

Comment 2 Vijay Bellur 2016-08-02 06:53:42 UTC
REVIEW: http://review.gluster.org/15068 (meta: fix memory leak in meta xlators) posted (#1) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 3 Vijay Bellur 2016-08-05 10:57:00 UTC
COMMIT: http://review.gluster.org/15068 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit d297d2bdfc4d5ba99c37b22dd1ae0f8e8e92fe7b
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Tue Aug 2 11:59:42 2016 +0530

    meta: fix memory leak in meta xlators
    
    meta xlator is leaking iobuf and iobrefs in read path
    
    This patch fixes memleak in meta_default_read code path
    
    Change-Id: Ieb413267604d9870dbe6e11258fffd279a7bd7cf
    BUG: 1362397
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/15068
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Poornima G <pgurusid@redhat.com>

Comment 4 Vijay Bellur 2016-08-05 14:06:58 UTC
REVIEW: http://review.gluster.org/15102 (meta: fix memory leak in meta xlators) posted (#1) for review on release-3.7 by Oleksandr Natalenko (oleksandr@natalenko.name)

Comment 5 Shyamsundar 2017-03-27 18:18:24 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.9.0, please open a new bug report.

glusterfs-3.9.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2016-November/029281.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.