Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1362279 - docker-1.12: docker run /nonexistent: wrong exit code
Summary: docker-1.12: docker run /nonexistent: wrong exit code
Keywords:
Status: VERIFIED
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: docker
Version: 7.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Daniel Walsh
QA Contact: atomic-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-01 19:45 UTC by Ed Santiago
Modified: 2019-03-06 00:56 UTC (History)
3 users (show)

Fixed In Version: docker-latest-1.12.1-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description Ed Santiago 2016-08-01 19:45:50 UTC
docker-run(1), as of docker-1.10, documents exit status 127 as follows:

   127 if the contained command cannot be found

docker-1.10 works as expected:

   # docker run  registry.access.redhat.com/rhel7/rhel /usr/bin/nonesuch;echo $?
   exec: "/usr/bin/nonesuch": stat /usr/bin/nonesuch: no such file or directory
   docker: Error response from daemon: Container command not found or does not exist..
   127

docker-1.12.0-6.el7.x86_64 instead exits with 125 and an unexpected error:

   # docker run  registry.access.redhat.com/rhel7/rhel /usr/bin/nonesuch;echo $?
   /usr/bin/docker-current: Error response from daemon: oci runtime error: exit status 1:.
   125

Comment 2 smahajan@redhat.com 2016-08-02 17:41:04 UTC
Ed,

I tried this with upstream docker 1.12 and getting error code 127.
http://pastebin.test.redhat.com/398465

How did you setup docker 1.12 on the machine ? The reason I am asking this is because, with docker 1.12 there are multiple binaries that needs to communicate with each other. 

binaries: docker, dockerd, runc, docker-containerd, docker-container-shim

Shishir

Comment 3 Ed Santiago 2016-08-02 18:06:47 UTC
Shishir,

This was an upgrade from docker-1.10.3-44.el7.x86_64 to 1.12.0-1.el7.x86_64 on a fresh system, i.e. docker had been installed and started but never actually run anything. I then added a VG and ran docker-storage-setup (under 1.12) but *did not* restart rhel-push-plugin or docker-containerd. (ref. bug 1360892). I've just restarted those, and docker as well, but get the same 125 code and oci runtime error.

I am in the process of trying this with a fresh docker-1.12 install.

Comment 4 Ed Santiago 2016-08-02 21:40:58 UTC
No joy. Fresh install, same thing:

    # docker run fedora /usr/bin/nonesuch; echo $?
    /usr/bin/docker-current: Error response from daemon: oci runtime error: exit status 1:.
    125

    # rpm -qa|egrep 'docker|oci'|sort
    docker-1.12.0-6.el7.x86_64
    docker-common-1.12.0-6.el7.x86_64
    docker-rhel-push-plugin-1.12.0-6.el7.x86_64
    docker-selinux-1.12.0-6.el7.x86_64
    oci-register-machine-0-1.7.git31bbcd2.el7.x86_64
    oci-systemd-hook-0.1.4-4.git41491a3.el7.x86_64

(oci-systemd-hook-0.1.4-4 because I tried yum downgrade & restarting docker/docker-containerd. Otherwise, oci-systemd-hook-1:0.1.4-6.git337078c.el7.x86_64)

All packages are from brew.

Comment 8 Ed Santiago 2016-08-30 23:15:12 UTC
Symptoms gone in docker-latest-1.12.1-2.el7; it appears to have been part of the oci-register-machine issue.


Note You need to log in before you can comment on or make changes to this bug.