Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1362260 - ipa vault-mod no longer allows defining salt
Summary: ipa vault-mod no longer allows defining salt
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Kaleem
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-01 18:36 UTC by Scott Poore
Modified: 2016-11-04 05:59 UTC (History)
3 users (show)

Fixed In Version: ipa-4.4.0-5.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 05:59:47 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Scott Poore 2016-08-01 18:36:30 UTC
Description of problem:

The salt option to specify salt from command line is missing:

[root@rhel7-1 ~]# ipa vault-mod --salt
Usage: ipa [global-options] vault-mod NAME [options]

ipa: error: no such option: --salt


Version-Release number of selected component (if applicable):
ipa-server-4.4.0-4.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1.  install IPA server
2.  ipa vault-mod --salt

Actual results:
shown above

Expected results:
Should accept salt from command line like previous versions.


Additional info:

Comment 3 Jan Cholasta 2016-08-02 07:42:12 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/6154

Comment 4 Jan Cholasta 2016-08-04 12:17:34 UTC
Fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/1a73477e1561b0a2a66852575010a136edc014a6

Comment 6 Scott Poore 2016-08-05 16:12:32 UTC
Verified.

Version ::

ipa-server-4.4.0-5.el7.x86_64

Results ::

[root@rhel7-5 yum.local.d]# ipa vault-mod --salt
Usage: ipa [global-options] vault-mod NAME [options]

ipa: error: --salt option requires an argument


And to see it work:

[root@rhel7-5 yum.local.d]# ipa vault-add --type=symmetric testvault1 --password=1234
------------------------
Added vault "testvault1"
------------------------

[root@rhel7-5 yum.local.d]# ipa vault-mod testvault1 --salt VGVTdE5ld1NhbFQK --old-password=1234 --new-password=12345
---------------------------
Modified vault "testvault1"
---------------------------

Comment 8 errata-xmlrpc 2016-11-04 05:59:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.