Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1362236 - Upgrade to Sat 6.2 fails when proxy registration happens before Apache is started
Summary: Upgrade to Sat 6.2 fails when proxy registration happens before Apache is sta...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Docs Install Guide
Version: 6.2.0
Hardware: x86_64
OS: Linux
high
high vote
Target Milestone: Unspecified
Assignee: Stephen Wadeley
QA Contact: satellite-doc-list
URL:
Whiteboard:
: 1360938 1362559 (view as bug list)
Depends On:
Blocks: CEE_Sat6_Top_BZs, GSS_Sat6_Top_Bugs 1362234
TreeView+ depends on / blocked
 
Reported: 2016-08-01 16:09 UTC by Ash Westbrook
Modified: 2016-10-19 09:53 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-19 09:53:17 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1363731 None None None Never
Red Hat Knowledge Base (Solution) 2479161 None None None 2016-08-15 22:34:37 UTC

Internal Links: 1363731

Description Ash Westbrook 2016-08-01 16:09:05 UTC
Description of problem:

Satellite upgrade for some customers fails with:

 "[ERROR 2016-07-29 14:30:14 verbose]  /Stage[main]/Foreman_proxy::Register/Foreman_smartproxy[<FQDN>]: Could not evaluate: Proxy <FQDN> cannot be registered (Connection refused - connect(2)): N/A"


Version-Release number of selected component (if applicable):

Satellite 6.1.9 upgrade attempt to 6.2.0

How reproducible:

I have reproduced this on my own private instance. Other customers have as well.

Steps to Reproduce:
1. https://access.redhat.com/documentation/en/red-hat-satellite/6.2/paged/installation-guide/chapter-6-upgrading-satellite-server-and-capsule-server

While running the command at step 17 " satellite-installer --scenario satellite --upgrade --verbose --noop"
2.hit issue
3.check installer log and find the a proxy error.
4. Seems to be the same issue as noted in this foreman bug with httpd not running:

projects.theforeman.org/issues/3083

Actual results:

upgrade fails


Expected results:

upgrade should succeed


Additional info:

Comment 2 Kathryn Dixon 2016-08-01 18:40:36 UTC
 satellite-installer --scenario satellite --upgrade --verbose

Running this without the --noops is successful for me.

Comment 3 Stephen Wadeley 2016-08-02 13:58:47 UTC
*** Bug 1362559 has been marked as a duplicate of this bug. ***

Comment 7 Chris Roberts 2016-08-12 23:43:43 UTC
*** Bug 1360938 has been marked as a duplicate of this bug. ***

Comment 8 Stephen Wadeley 2016-08-19 13:02:46 UTC
Hello

is this not really a docs bug?


Please see new text at link [1]


We changed the text a bit and used bold to emphasize that this was an optional step. We also added a substep to add an include line in '/etc/httpd/conf/httpd.conf' for '/etc/httpd/conf.modules.d/*.conf' to stop the error occurring that was confusing people.

This is the fist two lines from the step (currently step 18) at [1]

QUOTE: If you have custom configurations, they will be reverted to the installation defaults in the next step. If you want to see what will be changed *when you perform the upgrade*,


near the end is this line:

QUOTE: to see what changes *would be applied* if the --noop option was omitted 




[1]
https://access.redhat.com/documentation/en/red-hat-satellite/6.2/paged/installation-guide/chapter-6-upgrading-satellite-server-and-capsule-server#upgrading_satellite_server

Comment 9 Xixi 2016-10-04 22:50:02 UTC
Bug 1363731 - Error while trying to evaluate the Satellite upgrade process using --noop option 
looks like a duplicate of this one

Comment 11 Stephen Wadeley 2016-10-19 09:53:17 UTC
Hello

Changes as per BZ#1367674 are now live on the customer portal.


Note You need to log in before you can comment on or make changes to this bug.