Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1362232 - Setting RPCBIND_ARGS results in rpcbind startup failure 'invalid option'
Summary: Setting RPCBIND_ARGS results in rpcbind startup failure 'invalid option'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rpcbind
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Steve Dickson
QA Contact: Yongcheng Yang
URL:
Whiteboard:
Depends On: 1362201
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-01 16:01 UTC by Steve Dickson
Modified: 2016-11-04 02:10 UTC (History)
5 users (show)

Fixed In Version: rpcbind-0.2.0-38.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1362201
Environment:
Last Closed: 2016-11-04 02:10:55 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2274 normal SHIPPED_LIVE rpcbind bug fix and enhancement update 2016-11-03 13:35:05 UTC

Description Steve Dickson 2016-08-01 16:01:49 UTC
+++ This bug was initially created as a clone of Bug #1362201 +++

Description of problem:
Changing RPCBIND_ARGS in /etc/sysconfig/rpcbind results in startup failures for rpcbind.

Version-Release number of selected component: rpcbind-0.2.3-10.rc1.fc24.x86_64


Steps to Reproduce:
1. Modify the contents of /etc/sysconfig/rpcbind here is an example line that fails:

  RPCBIND_ARGS="-l -h 10.1.10.2"
 
2. Attempt to restart rpcbind.  Start will fail

   systemctl restart rpcbind


Actual results:

Jul 31 21:22:06 mirth.inuus.com rpcbind[3781]: /sbin/rpcbind: invalid option -- ' '
Jul 31 21:22:06 mirth.inuus.com rpcbind[3781]: usage: rpcbind [-adhilswf]


Expected results:

Successful startup of rpcbind with arguments


Additional info:

It appears that removing the braces from the ${RPCBIND_ARGS} in /usr/lib/systemd/system/rpcbind.service fixes this issue.  This appears to be what other services use.

Comment 5 Yongcheng Yang 2016-08-04 06:33:24 UTC
Move to VERIFIED as comment 4, and will continue to run the automatic case.

Comment 7 errata-xmlrpc 2016-11-04 02:10:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2274.html


Note You need to log in before you can comment on or make changes to this bug.