Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1362205 - [RFE] request for retirement process to examine retirement date on each VM to determine if date in VM is in agreement with the 'retire now' action about to be performed
Summary: [RFE] request for retirement process to examine retirement date on each VM to...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate
Version: 5.6.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: GA
: cfme-future
Assignee: John Hardy
QA Contact: Dmitry Misharov
URL:
Whiteboard: retirement
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-01 14:20 UTC by Thomas Hennessy
Modified: 2019-01-25 20:29 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-25 20:29:02 UTC
Category: ---
Cloudforms Team: ---


Attachments (Terms of Use)

Description Thomas Hennessy 2016-08-01 14:20:14 UTC
Description of problem: Customer reports that if he creates a VM to be retired tomorrow and then laster changes his mind to extend the retirment, the VM still gets retired at midnight that night


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Provision a new vm with a retirment date of tomorrow
2. wait several hours and then extend the retirement date on the VM to some other future date.
3.

Actual results:
customer reports that VM is retired tomorrow even thought the "then current" retirement date in the VM is not in agreement with the then current retirement date.

Expected results: VM would be retired on specified retirement date


Additional info:
It seems that there is a periodic process within CFME to schedule VM retirments, but there is no confirmation process to ensure that a scheduled VM retire is still the desired action recorded in the VM at the time that retirement is initiated.

Comment 7 Tina Fitzgerald 2017-10-04 15:25:52 UTC
Hi Kevin and Loic,

I've heard differing views on this, especially since you can add VM's to a Service and they could already have a retirement date specified.

Thanks,
Tina

Comment 8 Kevin Morey 2017-10-04 15:53:10 UTC
Yes that is a very valid use case too. The point is we should be able to modify the behavior of a service so that all resources can share the same retirement or manage them independently.


Note You need to log in before you can comment on or make changes to this bug.