Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1362193 - [engine-backend] NPE for a failed GetCapabilitiesVDSCommand
Summary: [engine-backend] NPE for a failed GetCapabilitiesVDSCommand
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: vdsm-jsonrpc-java
Classification: oVirt
Component: Core
Version: 1.2
Hardware: x86_64
OS: Unspecified
high
high vote
Target Milestone: ovirt-4.0.5
: 1.2.6
Assignee: Piotr Kliczewski
QA Contact: Lukas Svaty
URL:
Whiteboard:
: 1386710 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-01 13:34 UTC by Elad
Modified: 2017-05-21 01:58 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-18 07:37:21 UTC
oVirt Team: Infra
rule-engine: ovirt-4.0.z+
mgoldboi: planning_ack+
mperina: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)
engine.log, server.log, vdsm.log (deleted)
2016-08-01 13:34 UTC, Elad
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 61783 master MERGED make sure that channel is protected by the lock 2016-09-23 11:50:28 UTC
oVirt gerrit 65089 ovirt-4.0 MERGED make sure that channel is protected by the lock 2016-10-05 07:49:39 UTC
oVirt gerrit 65389 ovirt-4.0 MERGED version bump 2016-10-12 09:11:12 UTC
oVirt gerrit 65391 ovirt-engine-4.0 MERGED jsonrpc: version bump 2016-10-12 13:01:33 UTC
oVirt gerrit 65529 ovirt-engine-4.0.5 MERGED jsonrpc: version bump 2016-10-17 12:58:57 UTC
oVirt gerrit 67914 master ABANDONED Use a task to close the channel instead of lock 2017-05-21 01:58:45 UTC

Description Elad 2016-08-01 13:34:28 UTC
Created attachment 1186434 [details]
engine.log, server.log, vdsm.log

Description of problem:
While a host in a non responsive state, GetCapabilitiesVDSCommand fails with a NullPointerException.

Version-Release number of selected component (if applicable):
rhevm-4.0.2.3-0.1.el7ev.noarch


How reproducible:
100%

Steps to Reproduce:
1. Block connectivity between host and engine or reboot the host 


Actual results:

Host moves to non-responsive and GetCapabilitiesVDSCommand fails with a NullPointerException:

2016-08-01 16:30:01,116 WARN  [org.ovirt.engine.core.vdsbroker.VdsManager] (DefaultQuartzScheduler7) [5ce6392] Failed to refresh VDS , vds = 'green-vdsd' : '78df4cbc-f574-489c-8ec2-7b3c9831194e', error = 'null', continuing.
2016-08-01 16:30:01,116 ERROR [org.ovirt.engine.core.vdsbroker.VdsManager] (DefaultQuartzScheduler7) [5ce6392] Exception: java.lang.NullPointerException


Expected results:
No NPE

Additional info:
engine.log, server.log, vdsm.log

Comment 1 Martin Perina 2016-08-01 15:20:23 UTC
NPE looks ugly, but it does not affect activation of the host when connection issues are over, so targeting to 4.0.4

Comment 2 Lukas Svaty 2016-10-24 14:06:55 UTC
verified in vdsm-jsonrpc-java-1.2.6-1.el7ev.noarch

Comment 3 Piotr Kliczewski 2016-10-27 11:56:50 UTC
*** Bug 1386710 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.