Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1362162 - named-pkcs11 ABRT dumped core
Summary: named-pkcs11 ABRT dumped core
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: bind-dyndb-ldap
Version: 24
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Tomas Krizek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-01 12:34 UTC by Anthony Messina
Modified: 2016-12-02 13:28 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-02 13:28:59 UTC


Attachments (Terms of Use)
GDB output of bt full (deleted)
2016-08-02 13:23 UTC, Anthony Messina
no flags Details

Description Anthony Messina 2016-08-01 12:34:40 UTC
PID: 1977 (named-pkcs11)
           UID: 25 (25)
           GID: 25 (25)
        Signal: 6 (ABRT)
     Timestamp: Mon 2016-08-01 03:47:02 CDT (3h 40min ago)
  Command Line: /usr/sbin/named-pkcs11 -u named
    Executable: /usr/sbin/named-pkcs11
 Control Group: /
         Slice: -.slice
       Boot ID: 3cbd660c4f4d4dc6a722157e76d0baf8
    Machine ID: 6c15b0001cb74c9db679f0a2333fb692
      Hostname: ds.example.com
      Coredump: /var/lib/systemd/coredump/core.named-pkcs11.25.3cbd660c4f4d4dc6a722157e76d0baf8.1977.1470041222000000000000.lz4
       Message: Process 1977 (named-pkcs11) of user 25 dumped core.
                
                Stack trace of thread 313:
                #0  0x00007f08856866f5 raise (libc.so.6)
                #1  0x00007f08856882fa abort (libc.so.6)
                #2  0x000055c666ef62b8 n/a (/usr/sbin/named-pkcs11)


This is on a FreeIPA system in a systemd-nspawn container when issuing a systemctl reload named-pkcs11 with bind-pkcs11-9.10.4-1.P2.fc24 (the upgrade from yesterday)




Aug 01 07:32:15 ipa.example.com named-pkcs11[2593]: zt.c:186: REQUIRE(ztp != ((void *)0) && *ztp == ((void *)0)) failed, back trace
Aug 01 07:32:15 ds.example.com audit[14011]: ANOM_ABEND auid=4294967295 uid=25 gid=25 ses=4294967295 subj=system_u:system_r:virtd_lxc_t:s0:c10,c11 pid=14011 comm="named-pkcs11" exe="/usr/sbin/named-pkcs11" sig=6
Aug 01 07:32:15 ipa.example.com named-pkcs11[2593]: #0 0x55b158f49110 in ??
Aug 01 07:32:15 ipa.example.com named-pkcs11[2593]: #1 0x7f5e8a30bc4a in ??
Aug 01 07:32:15 ipa.example.com named-pkcs11[2593]: #2 0x7f5e8a6e7f22 in ??
Aug 01 07:32:15 ipa.example.com named-pkcs11[2593]: #3 0x7f5e7ef5a2ba in ??
Aug 01 07:32:15 ipa.example.com named-pkcs11[2593]: #4 0x7f5e7ef5a4b0 in ??
Aug 01 07:32:15 ipa.example.com named-pkcs11[2593]: #5 0x7f5e7ef5a604 in ??
Aug 01 07:32:15 ipa.example.com named-pkcs11[2593]: #6 0x7f5e8a32e90c in ??
Aug 01 07:32:15 ipa.example.com named-pkcs11[2593]: #7 0x7f5e8845a5ca in ??
Aug 01 07:32:15 ipa.example.com named-pkcs11[2593]: #8 0x7f5e874d3ead in ??
Aug 01 07:32:15 ipa.example.com named-pkcs11[2593]: exiting (due to assertion failure)
Aug 01 07:32:15 ipa.example.com systemd[1]: Reloaded Berkeley Internet Name Domain (DNS) with native PKCS#11.
Aug 01 07:32:15 ipa.example.com polkitd[2452]: Unregistered Authentication Agent for unix-process:2744:7902359 (system bus name :1.25, object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8) (disconnected from bus)
Aug 01 07:32:15 ds.example.com systemd[1]: Started Process Core Dump (PID 14956/UID 0).
Aug 01 07:32:15 ds.example.com audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=systemd-coredump@2-14956-0 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Aug 01 07:32:16 ipa.example.com systemd[1]: named-pkcs11.service: Main process exited, code=killed, status=6/ABRT
Aug 01 07:32:16 ipa.example.com sh[2756]: kill: not enough arguments
Aug 01 07:32:16 ipa.example.com systemd[1]: named-pkcs11.service: Control process exited, code=exited status=1
Aug 01 07:32:16 ipa.example.com systemd[1]: named-pkcs11.service: Unit entered failed state.
Aug 01 07:32:16 ipa.example.com systemd[1]: named-pkcs11.service: Failed with result 'exit-code'.
Aug 01 07:32:16 ds.example.com systemd-coredump[14958]: Process 14010 (named-pkcs11) of user 25 dumped core.
                                                         
                                                         Stack trace of thread 2594:
                                                         #0  0x00007f5e874056f5 raise (libc.so.6)
                                                         #1  0x00007f5e874072fa abort (libc.so.6)
                                                         #2  0x000055b158f492b8 n/a (/usr/sbin/named-pkcs11)

Comment 1 Tomáš Hozza 🤓 2016-08-02 13:04:42 UTC
Hello.

The description does not contain enough information for us to investigate the issue, especially because the traceback does not contain information about function names and lines.

Please provide the coredump or install debuginfo packages and attach the full traceback when named-pkcs11 crashes the next time.

Thank you.

Comment 2 Anthony Messina 2016-08-02 13:23:25 UTC
Created attachment 1186825 [details]
GDB output of bt full

Comment 3 Jochen Demmer 2016-09-13 17:12:05 UTC
I can confirm the exact same behaviour in my environment, which is why I would like to see that fixed as soon as possible.

DNS just HAS to work

Comment 4 Petr Spacek 2016-09-20 07:00:34 UTC
Guessing from the backtrace, this might be a bug in bind-dyndb-ldap. I will have a look.

Comment 5 Petr Spacek 2016-09-20 07:02:26 UTC
Relevant e-mail thread:
https://www.redhat.com/archives/freeipa-users/2016-September/msg00139.html

It seems that bind-dyndb-ldap-10.1-1.fc24 from updates-testing fixed the issue:
https://www.redhat.com/archives/freeipa-users/2016-September/msg00291.html

Comment 6 Anthony Messina 2016-09-25 16:37:52 UTC
This seems to be fixes by https://bodhi.fedoraproject.org/updates/FEDORA-2016-ea30aafae1

Comment 7 Fedora Admin XMLRPC Client 2016-12-02 09:10:31 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 8 Anthony Messina 2016-12-02 13:28:59 UTC
(In reply to Anthony Messina from comment #6)
> This seems to be fixes by
> https://bodhi.fedoraproject.org/updates/FEDORA-2016-ea30aafae1

As reported, this has been fixed.


Note You need to log in before you can comment on or make changes to this bug.