Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1362105 - missing module enum for ovirtsdk4
Summary: missing module enum for ovirtsdk4
Keywords:
Status: CLOSED DUPLICATE of bug 1349774
Alias: None
Product: ovirt-engine-sdk-python
Classification: oVirt
Component: Core
Version: 4.0.0a
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: ---
: ---
Assignee: Ondra Machacek
QA Contact: Pavel Stehlik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-01 09:55 UTC by movciari
Modified: 2016-08-01 10:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-01 10:00:56 UTC
oVirt Team: Infra
movciari: planning_ack?
movciari: devel_ack?
movciari: testing_ack?


Attachments (Terms of Use)

Description movciari 2016-08-01 09:55:08 UTC
Description of problem:
On RHEL 7.2 where RHEV 4.0 is installed, which means ovirtsdk4 is installed there from RPM, "api = con.system_service()" gives "ImportError: No module named enum"

Version-Release number of selected component (if applicable):
python-ovirt-engine-sdk4-4.0.0-0.0.a3.el7ev.x86_64

How reproducible:
always

Steps to Reproduce:
1. from ovirtsdk4 import Connection
2. con = Connection(url='https://hostname/ovirt-engine/api', username='admin@internal', password='pass')
3. api = con.system_service()

Actual results:
ImportError: No module named enum

Expected results:
should return system service

Additional info:

Comment 1 Ondra Machacek 2016-08-01 10:00:56 UTC

*** This bug has been marked as a duplicate of bug 1349774 ***


Note You need to log in before you can comment on or make changes to this bug.