Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1362049 - [userinterface_public_689]It's better to remove auto focus at last name in key-value-editor on edit-buildconfig, create-fromtemplate and edit-autoscaler page
Summary: [userinterface_public_689]It's better to remove auto focus at last name in ke...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OKD
Classification: Red Hat
Component: Management Console
Version: 3.x
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: ---
Assignee: bpeterse
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-01 09:06 UTC by Yadan Pei
Modified: 2016-09-19 13:55 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-19 13:55:34 UTC


Attachments (Terms of Use)

Description Yadan Pei 2016-08-01 09:06:41 UTC
Description of problem:
When open create-fromtemplate, edit-buildconfig and edit-autoscaler page, it will auto focus at the last name of Labels/Enviroment Variables. It's better to remove the auto focus just like create-fromimage page does

Version-Release number of selected component (if applicable):
openshift v1.3.0-alpha.2+f6f7de3-dirty(latest origin-web-console)
kubernetes v1.3.0+57fb9ac
etcd 2.3.0+git


How reproducible:
Always

Steps to Reproduce:
1. Create a new project and add template to project
# oc new-project yapei-test
# oc create -f https://raw.githubusercontent.com/openshift/origin/master/examples/sample-app/application-template-stibuild.json
template "ruby-helloworld-sample" created
2. Login to web console, click Add to project
3. Select template "ruby-helloworld-sample" on Browse Catelog tab
4. Go to edit/builds/ruby-sample-build page
5. Go to edit/autoscaler?kind=DeploymentConfig&name=database page

Actual results:
3,4,5
When opening these pages, it will auto focus at the last Name of Labels/Environment

Expected results:
3,4,5
Should have no specific focus when entering these pages because we didn't know what user is going to edit/update

Additional info:

Comment 1 bpeterse 2016-08-02 14:07:19 UTC
also see this github issue: https://github.com/openshift/origin-web-console/issues/252

Comment 2 bpeterse 2016-08-03 13:41:25 UTC
Fix will merge today with PR#263 in origin-web-console

Comment 3 bpeterse 2016-08-03 19:26:00 UTC
MERGED: https://github.com/openshift/origin-web-console/pull/263

Comment 4 Yadan Pei 2016-08-05 10:05:44 UTC
Checked against devenv-rhel7_4763


Now when entering edit-buildconfig, create-fromtemplate and edit-autoscaler page, there is no auto focus in key-value-editor

Move to VERIFIED


Note You need to log in before you can comment on or make changes to this bug.