Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1362024 - [userinterface_public_689]Updated environment variables from edit-buildconfig page should be displayed correctly on BuildConfig Environment tab
Summary: [userinterface_public_689]Updated environment variables from edit-buildconfig...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OKD
Classification: Red Hat
Component: Management Console
Version: 3.x
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: bpeterse
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-01 08:10 UTC by Yadan Pei
Modified: 2016-12-09 21:52 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-09 21:52:35 UTC


Attachments (Terms of Use)
UpdateProcess (deleted)
2016-08-15 08:45 UTC, Yadan Pei
no flags Details
ServerConnectionInterrupted (deleted)
2016-08-15 08:54 UTC, Yadan Pei
no flags Details

Description Yadan Pei 2016-08-01 08:10:49 UTC
Description of problem:
Update bc environment variables via edit-buildconfig page, then check bc env vars on Environment tab, updated env vars are not shown, instead old env vars are still there. This reproduces on Chrome and Safari.
Firefox, IE and Edge could get latest env vars displayed

Version-Release number of selected component (if applicable):
openshift v1.3.0-alpha.2+f6f7de3-dirty(latest origin-web-console)
kubernetes v1.3.0+57fb9ac
etcd 2.3.0+git
Chrome 51
Safari 9.1


How reproducible:
Always

Steps to Reproduce:
1. Create a new project
2. Click Add to project, In Browse Catalog, select php:5.5 image
3. Set Name:php,Git Repository URL
4. Add one pair of key/value for BuildConfiguration BCkey1:BCvalue1
5. Hit on "Create" button
6. Go to Builds-> php -> Environment, BCkey1:BCvalue1 is displayed
7. Go to Builds -> php -> Actions -> Edit page, update BCkey1:BCvalue1 to BCkey1:BCvalue1update
8. Message "Build Config php was successfully updated" and redirect to Builds -> php -> Summary tab
9. Click Environment tab to check updated environment variables

Actual results:
9. Old env vars BCkey1:BCvalue1 is shown until hard refresh


Expected results:
9. Environment tab should always show latest env vars BCkey1:BCvalue1update

Additional info:

Comment 1 bpeterse 2016-08-03 18:43:39 UTC
Following these instructions I am unable to reproduce the bug.  At step 7 I am able to update the variable and press "save". When redirected back (step 8), and clicking "Environment" (step 9), the variable value correctly shows the updated value.

Comment 2 bpeterse 2016-08-03 18:46:56 UTC
Changing back to ON_QA for a double check.

Comment 3 Yadan Pei 2016-08-04 09:59:21 UTC
Hi Ben

Which browser did you use? 

Check against latest OCP 3.3.0.14, now this issue only reproduces in Chrome 51

Comment 4 Yadan Pei 2016-08-04 10:08:16 UTC
Could you please help try?

Comment 5 bpeterse 2016-08-04 13:52:08 UTC
Yup looking into it

Comment 6 bpeterse 2016-08-12 17:12:57 UTC
Tested with the following browsers and was not able to reproduce the issue.  Editing via the environment tab, the "edit" action and the "edit yaml" on build configs all updated as expected:
- (Win) IE 11, Chrome 51
- (Mac) Chrome 52, Safari 9.1, Firefox 45

However, I did notice some of the quirks mentioned in this ticket, depending on the browser: https://bugzilla.redhat.com/show_bug.cgi?id=1366457

Comment 7 Yadan Pei 2016-08-15 08:45:59 UTC
Created attachment 1190820 [details]
UpdateProcess

Comment 8 Yadan Pei 2016-08-15 08:53:43 UTC
Hi Ben, I attached screenshot of my side. I updated env value from test to test123456, but I didn't get test123456 in Environment tab.

I opened browser console and found some WebSocket error, so I think maybe there is some misconfiguration for me.

Comment 9 Yadan Pei 2016-08-15 08:54:25 UTC
Created attachment 1190825 [details]
ServerConnectionInterrupted

Comment 10 bpeterse 2016-08-15 13:53:19 UTC
Aha, yup! If there is a websocket issue this would def keep it from updating.

Comment 11 Yadan Pei 2016-08-16 01:24:30 UTC
Do I need to change some setting on my side? The websocket error is always the problem when testing web console features.

Comment 12 Yadan Pei 2016-08-17 06:30:41 UTC
Hi Ben, could you help answer my question in Comment 11 ? 

During web console testing, we often encounter scenarios like this: page is only refreshed until give a hard refresh, if you didn't give refresh page content will not be updated timely, do u know what's the problem?

Comment 13 Jessica Forrester 2016-08-17 14:31:44 UTC
David / Jordan, any thoughts as to why all the websockets would be failing to open (see comment 11 )?  They aren't in Safari so it shouldn't be related to certs.  The error code seems to be a timeout from the screenshot.

@yapei do you have a load balancer / apache set up in front of the master?

Comment 15 Jordan Liggitt 2016-08-17 19:07:22 UTC
> David / Jordan, any thoughts as to why all the websockets would be failing to open (see comment 11 )?

No...

Comment 16 Yadan Pei 2016-08-18 05:06:38 UTC
Hi Jessica,

I'm testing on OpenStack not AWS EC2.

Tried today against openshift v1.3.0-alpha.3+a6993d3
kubernetes v1.3.0+507d3a7
etcd 2.3.0+git


Now after saving changes in edit/build-config page, it will redirect to Summary tab, when switching to Environment tab, all changes are updated

Comment 17 bpeterse 2016-08-29 13:53:35 UTC
That sounds right. I don't think we've ever implemented a "tab you came from" feature, so this should be good.


Note You need to log in before you can comment on or make changes to this bug.