Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1362 - undefined symbol from egcs 1.1.1
Summary: undefined symbol from egcs 1.1.1
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: egcs
Version: 1.0
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
: 1365 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-02-27 17:39 UTC by roy
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-03-09 03:48:57 UTC


Attachments (Terms of Use)

Description roy 1999-02-27 17:39:14 UTC
I have a pretty freshly installed RedHat 5.2 machine. Wanted to bring egcs up to 1.1.x, so I grabbed the 1.1.1-7 rpm. The rpm had be upgrade cpp and binutils, both were no problem. Installing the new egcs was smooth, but when I try to run it:

roy@dt0f3n64 (1) % egcs -v
egcs: error in loading shared libraries
: undefined symbol: __register_frame_info

Is there some shared library that needs upgraded that wasn't
required by the rpm?

Comment 1 roy 1999-02-27 18:26:59 UTC
Okay, turns out 'nm' was broken too. The binutils .20 from Raw Hide 1.0 didn't want to work on my RH 5.2 box. I removed them, and installed a libc6 contrib RPM of binutils .19. 'nm' and company now work without error, but reinstalling egcs 1.1.1 still gives me:

[root@dt0f3n64 FTP]# egcs -v
egcs: error in loading shared libraries
: undefined symbol: __register_frame_info

  Maybe this isn't really a bug, just a side effect that I shouldn't be tryign to use any Raw Hide 1.0 RPMs...

Comment 2 stewart 1999-02-28 03:54:59 UTC
Either rebuild egcs from the source rpm, or else you have to upgrage
to glibc-2.1...  You cannot use binary rpms from rawhide without
upgrading glibc, or rebuilding the source

Comment 3 Jeff Johnson 1999-03-09 03:46:59 UTC
*** Bug 1365 has been marked as a duplicate of this bug. ***

I installed egcs 1.1.1 by upgrading a regular Linux 5.2
system on a Pentium233. First I uninstalled the old egcs,
egcs-c++, egcs-g77 and egcs-objc installation. Then I
upgraded binutils to 2.9.1.0.19a-2 and installed
cpp-1.1.1.7. Then I installed the new egcs packages (basic,
c++, g77 and objc).

Trying to run any of those compilers results in the
following error message:

[stacey@ferrari ~/test]>cc test.c
cc: error in loading shared libraries
: undefined symbol: __register_frame_info
[stacey@ferrari ~/test]>


Hints on how to solve this problem are very much
appreciated. Also, does egcs1.1.1-c++ handle namespace and
using correctly?


------- Additional Comments From schumann@me.queensu.ca  02/27/99 16:42 -------
I also installed libstdc++-2.9.0-7. I didn't have to uninstall
2.8.0-14 though.

------- Additional Comments From schumann@me.queensu.ca  02/27/99 16:43 -------
I also installed libstdc++-2.9.0-7. I didn't have to uninstall
2.8.0-14 though.

Comment 4 Jeff Johnson 1999-03-09 03:48:59 UTC
If you want to use Raw Hide rpm's on Red Hat 5.2, you *must*
recompile from the src rpm. Raw Hide rpm's use glibc-2.1 which
is not present on Red Hat 5.2.


Note You need to log in before you can comment on or make changes to this bug.