Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1361999 - Remove ganesha xlator code from gluster code base
Summary: Remove ganesha xlator code from gluster code base
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: ganesha-nfs
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jiffin
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-01 06:47 UTC by Jiffin
Modified: 2017-03-27 18:17 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.9.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-27 18:17:28 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Jiffin 2016-08-01 06:47:25 UTC
Description of problem:

Remove ganesha xlator code from gluster code base

Comment 1 Vijay Bellur 2016-08-01 06:47:41 UTC
REVIEW: http://review.gluster.org/15055 (xlators/ganesha : Remove the ganesha xlator code entirely from source) posted (#1) for review on master by jiffin tony Thottan (jthottan@redhat.com)

Comment 2 Vijay Bellur 2016-08-04 05:58:29 UTC
REVIEW: http://review.gluster.org/15055 (xlators/ganesha : Remove the ganesha xlator code entirely from source) posted (#2) for review on master by jiffin tony Thottan (jthottan@redhat.com)

Comment 3 Vijay Bellur 2016-08-04 15:43:22 UTC
COMMIT: http://review.gluster.org/15055 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit e4a404342cc1b53b1f16b68938f31d2b12dc9121
Author: Jiffin Tony Thottan <jthottan@redhat.com>
Date:   Mon Aug 1 12:11:24 2016 +0530

    xlators/ganesha : Remove the ganesha xlator code entirely from source
    
    ganesha xlator is dummy xlator which introduced as part of cli options.
    But all the ganesha related cli commands are handled from glusterd only.
    There is no point in keeping this xlator. Hence removing the same since
    it does not have any role in NFS-Ganesha intergration with gluster
    
    Change-Id: Id438d2fabd3afe7e91ae26522df8495c8e9e9308
    BUG: 1361999
    Signed-off-by: Jiffin Tony Thottan <jthottan@redhat.com>
    Reviewed-on: http://review.gluster.org/15055
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: soumya k <skoduri@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>

Comment 4 Shyamsundar 2017-03-27 18:17:28 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.9.0, please open a new bug report.

glusterfs-3.9.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2016-November/029281.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.