Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1361939 - [RFE] Include a mechanism to perform VMDB reindexing and full vacuums as necessitate by each table
Summary: [RFE] Include a mechanism to perform VMDB reindexing and full vacuums as nece...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance
Version: 5.6.0
Hardware: x86_64
OS: Linux
high
high
Target Milestone: GA
: 5.7.0
Assignee: Joe Vlcek
QA Contact: Alex Newman
URL:
Whiteboard: appliance:database
Depends On:
Blocks: 1382216
TreeView+ depends on / blocked
 
Reported: 2016-08-01 02:01 UTC by Thomas Hennessy
Modified: 2017-01-04 12:58 UTC (History)
11 users (show)

Fixed In Version: 5.7.0.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-04 12:58:42 UTC
Category: ---
Cloudforms Team: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0012 normal SHIPPED_LIVE CFME 5.7.0 bug fixes and enhancement update 2017-01-04 17:50:36 UTC

Description Thomas Hennessy 2016-08-01 02:01:52 UTC
Description of problem: no mechanism for VMDB table or index maintenance is provided in any release of cloudforms necessitating GSS to build and adpapt for each new release a set of scripts to perform continuous database maintenance to prevent the filesystem from filling when there is space available to be reclaimed and to  maintain CFME VMDB responsiveness.

This request is to implement something along the lines of what can be found via the article https://access.redhat.com/solutions/1419333 ("Continuous Maintenance for Cloudforms Management Engine VMDB to maintain Responsiveness ")


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Nick Carboni 2016-08-22 17:23:37 UTC
These scripts were added to the appliance in https://github.com/ManageIQ/manageiq-appliance/pull/85

Adjusted for upstream use in https://github.com/ManageIQ/manageiq-appliance/pull/86

And there is currently work in progress to make a configuration option to enable them on the appliance.

Comment 6 errata-xmlrpc 2017-01-04 12:58:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0012.html


Note You need to log in before you can comment on or make changes to this bug.