Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1361862 - overcloud update doesn't update the cephx key on the compute nodes [NEEDINFO]
Summary: overcloud update doesn't update the cephx key on the compute nodes
Keywords:
Status: CLOSED DUPLICATE of bug 1312765
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-puppet-modules
Version: unspecified
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
: 11.0 (Ocata)
Assignee: leseb
QA Contact: Yogev Rabl
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-31 10:45 UTC by Yogev Rabl
Modified: 2017-02-06 19:31 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-29 20:32:17 UTC
gfidente: needinfo? (yrabl)


Attachments (Terms of Use)

Description Yogev Rabl 2016-07-31 10:45:13 UTC
Description of problem:
I deployed the overcloud with external Ceph with one user, I tried to change the Ceph user I was using on the overcloud. After updating the overcloud, the cephx keyring of the Ceph user the key change doesn't affect the key that is was set in libvirt's secret on the Nova compute nodes. 

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-2.0.0-18.el7ost.noarch
openstack-tripleo-common-2.0.0-6.el7ost.noarch
openstack-tripleo-image-elements-0.9.9-6.el7ost.noarch
python-tripleoclient-2.0.0-1.0.6.el7ost.noarch
openstack-tripleo-heat-templates-kilo-2.0.0-18.el7ost.noarch
openstack-tripleo-heat-templates-liberty-2.0.0-18.el7ost.noarch
openstack-tripleo-puppet-elements-2.0.0-3.el7ost.noarch
openstack-tripleo-0.0.8-0.2.d81bd6dgit.el7ost.noarch


How reproducible:
100%

Steps to Reproduce:
1. deploy overcloud with 1 keyring 
2. update the details of the Ceph user in the environment file
3. launch an instance

Actual results:
Nova fails to launch instances due to bad configuration & lack of permissions on the Ceph storage


Expected results:
The keyring that is related to Libvirt's secret has changed during the update

Additional info:

Comment 4 Giulio Fidente 2016-11-16 18:27:50 UTC
looks like a duplicate of BZ 1312765?

Comment 5 Giulio Fidente 2016-11-29 20:32:17 UTC

*** This bug has been marked as a duplicate of bug 1312765 ***


Note You need to log in before you can comment on or make changes to this bug.