Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1361677 - Upgrades force docker 1.10 update
Summary: Upgrades force docker 1.10 update
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Upgrade
Version: 3.2.1
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.3.1
Assignee: Devan Goodwin
QA Contact: Anping Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-29 17:38 UTC by Eric Rich
Modified: 2016-10-27 16:12 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Incorrect logic interpreting inventory variables that control the version of docker to configure. Consequence: It was not possible to upgrade OpenShift and stay on docker < 1.10. Fix: Upgrade now respects docker_version and docker_upgrade inventory variables. Result: Users can now upgrade and control the version of docker to be installed more explicitly.
Clone Of:
Environment:
Last Closed: 2016-10-27 16:12:39 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2122 normal SHIPPED_LIVE OpenShift Container Platform atomic-openshift-utils bug fix update 2016-10-27 20:11:30 UTC

Description Eric Rich 2016-07-29 17:38:47 UTC
Description of problem:

Upgrades for the use of docker 1.10 even thought docker 1.9 is supported. 

Version-Release number of selected component (if applicable): 3.1 > 3.2

How reproducible: 100% 

Steps to Reproduce:
1. Run upgrade script and set docker_upgrade=false

Actual results:

Upgrade fails because the upgrade script requires docker 1.10 

Expected results:

Upgrade should happen and not update docker to 1.10 

Additional info:

  - fail:
      msg: This playbook requires access to Docker 1.10 or later
    when: g_docker_version.avail_version | default(g_docker_version.curr_version, true) | version_compare('1.10','<')

Comment 1 Ryan Howe 2016-07-29 18:28:32 UTC
This PR should resolve this bug. 

https://github.com/openshift/openshift-ansible/pull/1945

Comment 2 Eric Rich 2016-08-02 14:59:14 UTC
The usage of "docker_version=1.9.1" in the host file also does not seem to help with this.

Comment 3 Scott Dodson 2016-08-02 15:13:29 UTC
Can you check the version of the installer in use? This is believed to be fixed in the latest version of the 3.2 installer.

Comment 4 Eric Rich 2016-08-03 13:28:36 UTC
(In reply to Scott Dodson from comment #3)
> Can you check the version of the installer in use? This is believed to be
> fixed in the latest version of the 3.2 installer.

atomic-openshift-utils-3.2.13-1.git.0.0afa976.el7.noarch

Comment 5 Scott Dodson 2016-08-12 16:55:21 UTC
Fixed in https://github.com/openshift/openshift-ansible/pull/2285

Comment 6 Scott Dodson 2016-08-12 17:36:27 UTC
Nevermind, not fixed.

Comment 7 Devan Goodwin 2016-08-15 13:05:21 UTC
Fixed in https://github.com/openshift/openshift-ansible/pull/2295, you can now override this requirement with either docker_version or docker_upgrade.

Comment 9 Anping Li 2016-10-08 01:57:15 UTC
Can't install openshift-ansible-playbooks-3.3.30

[root@qe-upgrade-working host1]# dnf install atomic-openshift-utils
Last metadata expiration check performed 0:02:03 ago on Sat Oct  8 01:49:35 2016.
Error: nothing provides openshift-ansible-callback-plugins = 3.3.30 needed by openshift-ansible-playbooks-3.3.30-1.git.0.b260e04.el7.noarch
(try to add '--allowerasing' to command line to replace conflicting packages)

Comment 11 Anping Li 2016-10-13 01:38:12 UTC
Blocked by https://bugzilla.redhat.com/show_bug.cgi?id=1383189

Comment 12 Anping Li 2016-10-14 05:56:55 UTC
docker_version still 1.9.1 after upgrade when We enabled docker-upgrade=false

Comment 14 errata-xmlrpc 2016-10-27 16:12:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:2122


Note You need to log in before you can comment on or make changes to this bug.