Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1361626 - squid crashes with clients trying to ftp PUT a 0 bytes file
Summary: squid crashes with clients trying to ftp PUT a 0 bytes file
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: squid
Version: 7.4
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Luboš Uhliarik
QA Contact: Jan Houska
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-29 14:55 UTC by Felipe Zipitría
Modified: 2017-08-01 21:35 UTC (History)
4 users (show)

Fixed In Version: squid-3.5.20-6.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 21:35:36 UTC


Attachments (Terms of Use)
Patch from upstream. (deleted)
2016-07-29 15:03 UTC, Felipe Zipitría
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2174 normal SHIPPED_LIVE squid bug fix and enhancement update 2017-08-01 18:40:34 UTC
CentOS 11241 None None None 2016-07-29 14:55:10 UTC

Description Felipe Zipitría 2016-07-29 14:55:10 UTC
Description of problem:

In version from upstream, squid 3.3.8 has a bug which keeps crashing the proxy server.

2016/07/25 11:56:36| assertion failed: Server.cc:246: "r->body_pipe != NULL" 2016/07/25 11:56:40| Starting Squid Cache version 3.3.8 for x86_64-redhat-linux-gnu...

Version-Release number of selected component (if applicable):

3.3.8

How reproducible: Always

Steps to Reproduce:
1. generate empty file ( e.g. : > empty.txt)
2. export ftp_proxy=http://<yourproxy>:3128
3. lftp -c 'open <yourftphost>; put empty.txt'

Actual results: Squid server crashes and restart. Your lftp client willl try to do the same in 30 seconds... so it will keep crashing your server until yo do something.


Expected results: Create an empty file in the ftp server, and the squid server keeps working.


Additional info: upstream already have corrected this bug: http://bugs.squid-cache.org/show_bug.cgi?id=3498

Comment 1 Felipe Zipitría 2016-07-29 15:03:07 UTC
Created attachment 1185590 [details]
Patch from upstream.

Attachment applied to CentOS version of the package, and tested ok there.

Comment 4 Felipe Zipitría 2016-08-01 14:42:59 UTC
BTW, this problem happens also in squid 3.1.23 in RHEL 6. We ended updating our servers to 7 hoping the new version will address this problem, without success.

Comment 9 errata-xmlrpc 2017-08-01 21:35:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2174


Note You need to log in before you can comment on or make changes to this bug.